reinstalling PREMIER ELEMENTS 10 (problem) as PREMIER ELEMENTS 14 TRAIL version crashes.

  • 1
  • Problem
  • Updated 2 years ago
i was having odd behavioral-problems with premier elements 10, which was functioning perfectly until about a couple weeks ago. i attempted a reinstall and was given a prompt to quit all applications: DYNAMIC LINK INSTALLER as the one listed. however i cannot find any such application/utility on my mac (os 10.9.5 i-7 277GHz w/ 12 MB RAM). upon cancelling the installer it states in the details that CAMERA PROFILES INSTALLER has already been updated...apparently another reason we can't install PE 10. when i click contact CUSTOMER SUPPORT (which i've already tried numerous times) it tells me i require a serial number which i already provided but was forced to cancel. i don't like to bug support for small things but it seems there's a big problem with this procedure and i'm hesitant to purchase ANY upgrades from a company who makes getting support nearly impossible....plus the fact that my PE 14 TRIAL appears to be a cartoonish-version of 10 and does me the favor of crashing ( [pre10aa/autonanalyzer10/source/pre_aa10/contentanalysis/plugin/descriptions/make/mac/../../src/apt/aptdescriptorworkeritem.cpp_71] ?
Photo of mcc

mcc

  • 3 Posts
  • 1 Reply Like
  • concerned

Posted 2 years ago

  • 1
Photo of mcc

mcc

  • 3 Posts
  • 1 Reply Like
what's the general time-expectancy to have ADOBE or one of it's eager-community respond to such issues?
Photo of Louise Graux

Louise Graux

  • 1 Post
  • 0 Reply Likes
Not a reply (sorry),but a LOUD echo:
I have had the same problem since December 2015 and all I get is an electronic run-around. NO Support whatsoever, just old canned verbiage which does not even apply to my problem (Adobe installation software asking for a piece of software which is NO LONGER available as per AdobeĀ  So-called Support!
I bought the wretched tool and I cannot even us it: THAT IS TOTAL FRAUD.
Anyone KEEP AWAY from ADOBE.