Registered products don't show as registered, but can't register them

  • 2
  • Problem
  • Updated 3 years ago
I have several registered Adobe products:
CS4, PSE6, PE12 (yes, I know they are old; they work just find and I like them).

THE PROBLEM:
They do not show up as registered on my Adobe personal page, but I am not allowed to register them.
When I try to register them, I get this message:
"This serial number has already been registered. Products can only be registered once."
So I can't try to do any of the things that I need registration to do, because they are not showing up and I'm not allowed to register them.
HOW DO I GET THIS FIXED?
Photo of David Rearwin

David Rearwin

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Make sure you are logging in under the same email address (Adobe ID) as you did when registering the software.
Photo of David Rearwin

David Rearwin

  • 2 Posts
  • 0 Reply Likes
Thanks, Chris,

That's a good idea and one that occurred to me, but I've had the same email address for years and don't recall ever using another one for Adobe.

I thought of trying a couple of old ones, but Adobe ID won't allow me to use them now that I'm logged in with my current (for several years) email address.

And I really don't want to open a can of worms by somehow closing out this Adobe account and trying to open another one with an old email address (which wouldn't work anymore anyway, so no way to get the customary confirmation email to activate the account).