Photoshop CS6: Refine Edge not working.

  • 4
  • Problem
  • Updated 3 years ago
  • (Edited)
This might be user error, but I'm having difficulty with the Refine Edge tool. When I use Quick Selection to highlight a subject, and click on Refine Edge, I am unable to add or remove part of the selected region from the mask. I can erase, or draw over, and it shows, until I depress the mouse, and it goes back to the original selection. See attached video. I'm using Photoshop CS6 13.0.1 64-bit on a Windows 7 machine. Here's a video demonstrating the problem: https://www.youtube.com/watch?v=b8iO95...
Photo of Josh Chaikin

Josh Chaikin

  • 3 Posts
  • 0 Reply Likes
  • annoyed

Posted 6 years ago

  • 4
Photo of Mike Shaw

Mike Shaw, Employee

  • 79 Posts
  • 53 Reply Likes
When the dialog first opens the tool is set to Refine Radius tool use this tool to remove unwanted parts. The Erase Refinements tool that you switched to when you started is to restore areas that you have used the Refine Radius tool to remove.
Photo of Pete Green

Pete Green, Customer Advocate

  • 711 Posts
  • 134 Reply Likes
Thanks for recording the video and posting it here Josh!

In my experience, the refine edge really works best when used on areas of transition, such as somebody's hair agains a background.

For that image, I'd probably mostly use just the quick selection tool, and perhaps use the refine edge around the right side of the statue, near the water splashes. Though, that will likely mask them in, but it is a better use-case for the refine-radius brush tool.

Here are some tutorials that cover the refine selection tools:
http://tv.adobe.com/watch/learn-photo...

http://tv.adobe.com/watch/visual-desi...

However it does look to me that the tool isn't behaving properly as you should see some variation in the mask after drawing with the radius brush.
To that end, I'd Try restoring your prefs: http://helpx.adobe.com/photoshop/usin...

Hope this helps :)
Photo of Josh Chaikin

Josh Chaikin

  • 3 Posts
  • 0 Reply Likes
Pete, thank you for the response. Unfortunately, restoring the default settings did not solve my problem. I still do not see any variation in trying to erase out unwanted areas. The videos, while useful in showing how powerful and useful the tool can be, fail to address my specific problem. I didn't have issues with refining like this in CS5.
Photo of Josh Chaikin

Josh Chaikin

  • 3 Posts
  • 0 Reply Likes
I am still having this issue. As for using the refine edge around areas of transition, etc...I don't think the tool is discriminate enough to decide that it will work on one thing versus another. I have used it on hair to the same result and have used large areas of contrast to exaggerate the problem. I simply cannot add to or remove from a selection.
Photo of virginia paul

virginia paul

  • 5 Posts
  • 0 Reply Likes
I have the same problem with the same equiptment as Josh.
Photo of virginia paul

virginia paul

  • 5 Posts
  • 0 Reply Likes
Still having the same problem.
Photo of virginia paul

virginia paul

  • 5 Posts
  • 0 Reply Likes
Having refine edge problems. When drawing with paint brush to refine edge,,when I (using pen tablet) pick up the pen or click my mouse , my painting edge vanishes .
Photo of Danny Tillotson

Danny Tillotson

  • 2 Posts
  • 0 Reply Likes
I found if my layer has a substantial amount of background first before I make the required selection then that works a lot better than if I were to make my refined edge based on a trimmed layer selection already. So, if I want to do the hair, I won't make a layer of a tight selection of the hair, I will first make a layer of loose hair and then use the selection tool to make a good selection before using refine edge. That trick works like a charm. I hope I made sense I struggled to explain that but I want to help. Good luck!
Photo of Stina Petersen

Stina Petersen

  • 1 Post
  • 0 Reply Likes
I am experiencing the same problem as Josh and Virginia but I am using Ps CC. What can I do about it?
Stina
Photo of Kent Deleone

Kent Deleone

  • 1 Post
  • 0 Reply Likes
Same problem here! I see this is a very old post but if anyone has figured anything out, I would love to hear it. This is driving me up the wall insane!
Photo of rhys

rhys

  • 1 Post
  • 0 Reply Likes
Make sure the image you are working on is RGB 8bit. Thats the only format I can get refine edge working. RAW, tiff and 16 bit doesnt seem to work..
Hope this helps
Photo of GABRIELLE VICKERY

GABRIELLE VICKERY

  • 2 Posts
  • 0 Reply Likes
I was having the same problem, but using Danny's tip has helped to solve it ;-)
I simply made my canvas size bigger, now it works!
Thanks Danny ;-)
Photo of Danny Tillotson

Danny Tillotson

  • 2 Posts
  • 0 Reply Likes
I'm glad I could be of help. Thanks for letting me know, it's good to see my comment helped someone. :)
Photo of Skytype

Skytype

  • 1 Post
  • 0 Reply Likes
RGB! Rhys' comment that it needs to be in RGB made it work. thanks!
Photo of Marla Haney

Marla Haney

  • 1 Post
  • 0 Reply Likes
Changed to 8 bit, was already RGB, tried smart object AND not smart object, still unable to use brush tool over the edge in Refine Edge; no way to paint edges because the 'tool' is now just a circle/slash, what happened? Did my CS5.1 get 'too old' and doesn't work anymore, trying to make me upgrade to the rented program?
Photo of GABRIELLE VICKERY

GABRIELLE VICKERY

  • 2 Posts
  • 0 Reply Likes
This is quite an old thread and I haven't used the tool recently, but I know what worked for me was this: The layer I was working on had a girl with lots of hair flowing around her. The layer behind was a simple block colour. The top girl layer had fewer problems in terms of of getting the refine edge tool to work by getting rid of a large portion of the white backround around her, so if I lassoed her roughly with a rectangle and deleted some of the white around her, then used the tool, it worked fine. Does that make any difference?