Photoshop CC 2019: Red square on image + others

  • 3
  • Problem
  • Updated 3 weeks ago
  • (Edited)
I have had these red squares appear on my images while editing a few times now at first I thought it was just an artifact, but when I save the image it is on there. I have previously just deleted it and then redone the work and it has been ok, so it doesn't do it all the time but is obviously annoying, it can also be different sizes this is just the most recent one. (Can happen with editing the RAW or the saved Tiff when going back to make changes) I am using the latest Photoshop version on Win 10. I've also had bad artifacts while zooming in and out while editing, and camera raw seems different in displaying some images with bad dithering/color separation on some photos e.g pink clouds on blue sky (looks better viewing with Windows photo viewer). I shoot my photos in RAW with a Nikon, my PC has a i7 5960x 32gb ram and RX480 8gb gpu    
Photo of Conrad Labone

Conrad Labone

  • 5 Posts
  • 2 Reply Likes

Posted 4 months ago

  • 3
Photo of Kukurykus

Kukurykus

  • 664 Posts
  • 176 Reply Likes
Photo of Conrad Labone

Conrad Labone

  • 5 Posts
  • 2 Reply Likes
Thanks I'll try the Legacy Compositing, may take a few edits to see if it works since it is random
Photo of Conrad Labone

Conrad Labone

  • 5 Posts
  • 2 Reply Likes
Still getting them, even had a blue one as well
Photo of Andrew Sender

Andrew Sender, Employee

  • 52 Posts
  • 26 Reply Likes
Hi Conrad,
We're sorry about your experience.  By any chance are you working with Image -> Mode -> 16 Bits/Channel ?
Also, have you tried restarting Photoshop shop after enabling "Legacy Compositing"

Sincerely,
Andrew
Photo of Conrad Labone

Conrad Labone

  • 5 Posts
  • 2 Reply Likes
Yes I did restart PS, I have not changed any settings from previous versions this is only since the latest update, I'm editing Nikon RAW files in ACR 16bit sRGB, then opening in PS (not changing Bit/channel) and it can happen when making adjustments from there or I can save a tiff which is fine then open it again later and it will have the square or again happen with adjustments. I just batch processed 50 photos with PS and 2 have the squares, I've also just done a edit of 200 in lightroom and all of them exported fine no squares. (Note: I first encountered the problem doing individual edits not only in batches)
Photo of Conrad Labone

Conrad Labone

  • 5 Posts
  • 2 Reply Likes
The squares on latest edits are more transparent than before as well, which maybe because of changing to legacy? (And the frequency of seeing them was more when doing single edits)
(Edited)
Photo of Andrew Sender

Andrew Sender, Employee

  • 52 Posts
  • 26 Reply Likes
Hi Conrad,
If you are okay with this, can you email us the PSD file display these red and/or blue squares?  You can email it to me at sender@adobe.com.
Andrew
Photo of Nina Rochette

Nina Rochette

  • 2 Posts
  • 1 Reply Like
Also happens in latest Bridge.
Photo of Andy Stockglausner

Andy Stockglausner

  • 1 Post
  • 0 Reply Likes
I have this same issue in both Photoshop and Lightroom.  It's annoying and we print yearbooks and we got really lucky that we caught a very small one on a kid's face on 1 photo out of hundreds that we exported.  What's the fix?
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 718 Posts
  • 308 Reply Likes
Hi Andy,

Thanks for the report. We are seeing this internally now. Do you recall what you were you doing in Photoshop when you started seeing the red square? 

Thanks,
Hannah
Photo of ron dyar

ron dyar

  • 4 Posts
  • 0 Reply Likes
seeing the same thing, posted in the adobe forums:
https://forums.adobe.com/message/10753151#10753151
Photo of Nina Kennett

Nina Kennett

  • 2 Posts
  • 0 Reply Likes
I am having same issues in Bridge + PS and as well as red boxes on some images I am also getting red tinges to a lot photos, mostly on skin.  Any ideas?  Thanks!
Photo of ron dyar

ron dyar

  • 4 Posts
  • 0 Reply Likes
still having this issue, would they update this if they fixed it? I see there are updates to ACR, Bridge and PS.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14841 Posts
  • 2022 Reply Likes
Did you install the updates? (make sure you install the Camera Raw 11.1 update) If so, are you still having an issue?
(Edited)
Photo of ron dyar

ron dyar

  • 4 Posts
  • 0 Reply Likes
I have updated one computer, but since I could never reproduce it at will I don't have a way to know it is fixed other than not seeing it for a period of time. I would prefer to see a note saying 'possible fix for red box issue' or 'includes bug fixes' - whatever makes sense. Otherwise I am not sure I want to chance an update. The ACR upgrade notes just says it is adding raw support - nothing about a bug fix. I run a photo lab and ship most orders, this particular issue has been very difficult as it is not always noticeable so we have shipped orders with bad prints and then have to reship the redos.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15079 Posts
  • 2148 Reply Likes
Camera Raw 11.1 should fix this issue. Please let us know if that is not the case.
(Edited)
Photo of ron dyar

ron dyar

  • 4 Posts
  • 0 Reply Likes
great!
thanks for the reply.
Photo of Vasya Omelchuk

Vasya Omelchuk

  • 2 Posts
  • 1 Reply Like
I have this problem with my Camera RAW, I checked all updates.., how to fix it?




some of my  syst nfo:
Adobe Photoshop Version: 20.0.2 20181219.r.30 2018/12/19: 1202136  x64
Number of Launches: 893
Operating System: Windows 10 64-bit
Version: 10 or greater 10.0.17134.1
System architecture: Intel CPU Family:6, Model:12, Stepping:3 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX, AVX2, HyperThreading
Physical processor count: 4
Logical processor count: 8
Processor speed: 4000 MHz
Built-in memory: 32711 MB
Free memory: 17973 MB
Memory available to Photoshop: 29955 MB
Memory used by Photoshop: 60 %
Alias Layers: Disabled.
Modifier Palette: Enabled.
Highbeam: Enabled.
Image tile size: 1028K
Image cache levels: 5
Font Preview: Medium
TextComposer: Latin
Display: 1
Display Bounds: top=0, left=0, bottom=1440, right=2560
OpenGL Drawing: Enabled.
OpenGL Allow Old GPUs: Not Detected.
OpenGL Drawing Mode: Advanced
OpenGL Allow Normal Mode: True.
OpenGL Allow Advanced Mode: True.
AIFCoreInitialized=1
AIFOGLInitialized=1
OGLContextCreated=1
NumGLGPUs=1
NumCLGPUs=1
NumNativeGPUs=0
glgpu[0].GLVersion="4.1"
glgpu[0].IsIntegratedGLGPU=0
glgpu[0].GLMemoryMB=4096
glgpu[0].GLName="NVIDIA GeForce GTX 980"
glgpu[0].GLVendor="NVIDIA Corporation"
glgpu[0].GLVendorID=4318
glgpu[0].GLDriverVersion="25.21.14.1771"
glgpu[0].GLRectTextureSize=16384
glgpu[0].GLRenderer="GeForce GTX 980/PCIe/SSE2"
glgpu[0].GLRendererID=5056
glgpu[0].HasGLNPOTSupport=1
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15068 Posts
  • 2130 Reply Likes
Different issue. Try the solution here for Force Camera Raw to use Windows DirectX or macOS Metal
Photo of Vasya Omelchuk

Vasya Omelchuk

  • 2 Posts
  • 1 Reply Like
Thank you, that helped me :)