Elements: Cannot access PSE 12 editor

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
You have a unique product if it would work! I purchased Elements12, Organizer works fine, I could sign in no problem. However, the editor part of this program is not accessible to me. Same problem many people have judging by the communications I have seen. This is very frustrating. The problem is not at my end, it is yours. Why don't you create a downloadable fix for this. I should not have to check my clock or go into my hosts file. That's your job. I do not want to use the Cloud yet, your brings me there always, I am not always connected to the internet so, why should I have to be. I just want to edit my photos. I want to return this product as it is of no use to me unless I can edit my photos. Please respond. Thank you. ane5of7@yahoo.ca
Photo of chloe peterson

chloe peterson

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of Pete Green

Pete Green, Customer Advocate

  • 710 Posts
  • 134 Reply Likes
Hi Chloe,

Sorry about the frustration with getting the Editor to start.

What specifically happens when you try to start the Editor?
Is this on Mac or Windows? Which version of the operating system?

You could try renaming the SLStore folder located in the following locations.

Win: C:\ProgramData\Adobe\Slstore
Mac: Library/Application Support/Adobe/SLStore

Rename the SLStore folder and try starting the Editor again.

Let us know how it goes.
Regards.
Pete
Photo of chloe peterson

chloe peterson

  • 4 Posts
  • 0 Reply Likes
Thank you for responding, I have Windows8, have checked the hosts file, firewall settings, and GlobalSign Root CA certificate is there to no avail. I can sign in to the Adobe site from my browser (firefox) but when trying to install the editor, which takes me to the ADA,it won't let me sign in, that's where the problem is, also, when I sign in on line, it shows that my location is Africa. I am unable to correct that either, weird. Please help.
It Seems the Adobe Download Assistant is the problem here. At least the beginning problem
Photo of chloe peterson

chloe peterson

  • 4 Posts
  • 0 Reply Likes
Oh, and why is it that the Organizer was installed with no problem but, the editor requires a separate installation. I still want to use the editor even if I am not on on line. Should I delete the existing ADA and reinstall? I actually did that already too. Is it a bad program I purchased?
Photo of chloe peterson

chloe peterson

  • 4 Posts
  • 0 Reply Likes
I'm in!! Wow, I love it! My internet service went down, I tried to access the Editor just because, and voila, it came right up, so happy, now I just opt out out of signing in and use the product I bought it for. I hope it stays that way. Thanks for trying to help and it I have problems I will get back to you