Photoshop CC 2015: Quick Export not working

  • 23
  • Problem
  • Updated 1 month ago
  • In Progress
  • (Edited)
So I keep having the problem with quick export not working. I have to quit Photoshop and go back in to get it functioning. This messes up my work flow is this a known issue or is it just me.

Windows 10 - 64 bit
most recent update to Photoshop CC 2015
Photo of Alex

Alex

  • 20 Posts
  • 2 Reply Likes

Posted 4 years ago

  • 23
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 102 Posts
  • 52 Reply Likes
Official Response
This is so incredibly helpful (a solid repro case)!  Logging this bug, setting to high priority and assigning it to the appropriate engineer to look at and fix.  Thank you!
Photo of Michele Hengeveld

Michele Hengeveld

  • 2 Posts
  • 0 Reply Likes
Just made the update to Photoshop CC 2017 and trying to quick export PNG (NOT WORKING).  Trying to use the Export as feature and it just circles and circles and circles and circles.  It has been circling for 10 minutes now.  This feature doe NOT work and I need this in order to create my Watermark to LightRoom...  When did you stop letting "save as" a png be an option in the "save as" area?  I need to convert my new logo.

ANY HELP would be most appreciated, especially if you can fix my problem.
Photo of Michele Hengeveld

Michele Hengeveld

  • 2 Posts
  • 0 Reply Likes
BTW - this is the 2nd time in two months there has been a problem with Photoshop after an update from creative cloud. 
Photo of Chad Drewery

Chad Drewery

  • 3 Posts
  • 2 Reply Likes
When my Photoshop quits exporting, the quick fix is to save everything, quit Photoshop, and then reopen it. Once open, I do the quick save as png or a save for web and select png before anything else.
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 102 Posts
  • 52 Reply Likes
Hi Michele,
File > Save As... should still support and have PNG in the Format drop down.  If that's not the case for you, something might have gone wrong on install.  We have a bug logged that we're currently looking at, where Quick Export and Export As... stop working if you attempt access those commands while your current file is being saved.  Chad Drewery's workaround is the current best solution to get them working again. You should also be able to save as PNG via File > Export > Save for Web (Legacy)...  Hope that is helpful. 
Photo of Jack Schulz

Jack Schulz

  • 3 Posts
  • 0 Reply Likes
This is a really old post and has been fixed for quite some time. However, another issue after the most recent update. When I try to transfer multiple shots from lightroom to phtoshop as layers, I get the same message, I need to upgrade the raw image editor to 6.10 or I will have issues. It IS on version 6.10, and to make sure I RELOADED version 6.10 and still get the message. Very annoying.
(Edited)
Photo of Chris Brightwell

Chris Brightwell

  • 4 Posts
  • 0 Reply Likes
It's not fixed, Jack. I'm running the latest update and when working on multiple files, the quick export option randomly stops functioning at all. Sometimes it works 15 times, then it stops and you have to quit and restart Photoshop. Sometimes it works once then stops. This is really annoying. I've always used "save for web" but it always defaults to the last folder used. I just want to save it to the same folder as my psd.
Photo of Founded Creative2

Founded Creative2

  • 5 Posts
  • 0 Reply Likes
This most defiantly has not been fixed again!!!! hence my return to see if adobe have pulled there fingers out but alas no. i cant do an export as its painfully slow so I'm trying to do a quick export. guess what doesn't work again like the last 3 updates. art boards have been one of the worst features ever added to photoshop, rushed through to keep up with sketch but poorly done. and yes I'm updated to the latest photoshop did it last week as having these issues
Photo of Jenn Bryant

Jenn Bryant

  • 1 Post
  • 0 Reply Likes
Same thing here. I'm wasting so much time with this problem. Come on Adobe!!!
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 102 Posts
  • 52 Reply Likes
Hi Jenn,  
We're working on this and still narrowing down a solid reproducible case.  I've been able to get into this state where it stops working by trying to access Quick Export and/or Export As.. while the current doc is being saved.  Can you confirm that this is what is happening for you?  If you quit and restart does Quick Export work again?
Photo of Chris Brightwell

Chris Brightwell

  • 4 Posts
  • 0 Reply Likes
Chad, I'm having this issue as well... but it's random. I work on multiple files at a time and need to export jpegs for proofing. I've always used "save for web" but it annoyingly defaults to the last folder you used, not the current folder for the file you're working on. I just recently discovered "quick export as jpeg" which would be great if it had a shortcut command. Also if it worked consistently. It will sometimes work 15 times in a row, then it just stops responding. Nothing happens. Sometimes it will work once, then it stops. The only fix I've found is to quit and restart Photoshop, which is incredibly annoying. It's killing my production time at work.
Photo of Chris Brightwell

Chris Brightwell

  • 4 Posts
  • 0 Reply Likes
And in all cases, I've just saved the file and it has finished saving. Then I export my jpeg. I'm not exporting while the save function is running.
Photo of Chris Brightwell

Chris Brightwell

  • 4 Posts
  • 0 Reply Likes
Ok... so I've just discovered that I can use the hotkeys for "Export As..." the same way I did for "Save for Web." It's a little slower, but at least it chooses the root folder from your psd as a starting point. Very nice. Question for you... why does it consider the file altered and require another save if I use "Export As..." as opposed to the quick export option, which doesn't?
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 102 Posts
  • 52 Reply Likes
Export As... will store the options you choose (such as filetype, quality) for that document so they will be defaulted next time you open the file.
Photo of Jeroen Hoekstra

Jeroen Hoekstra

  • 3 Posts
  • 1 Reply Like
The problem is here as well. Running the latest update in CC of Photoshop so I guess the problem is not fixed... in .. 3 years !? seriously?
Photo of Kukurykus

Kukurykus

  • 664 Posts
  • 181 Reply Likes
It works for me in CC 19.1.5 from 'Layer / Quick Export as PNG' menu, however it always saves files with 72 px/in resolution but I guess it should with that document got? It seems another bug found?
(Edited)
Photo of Jeroen Hoekstra

Jeroen Hoekstra

  • 3 Posts
  • 1 Reply Like
It should save the png in the same pixel dimensions as in the file.
for instance if you have a button of 100px x 100px in the layer, the png will be 100 by 100 pixels. If you resize the element you export from the layer the size should be bigger because it takes up more pixels.

For some ( larger ) files with many smart objects ( vector ) the export to png from layer export "randomly" stops working. clicking the button and no result.

Copying the layer into a "new" file makes it work again. No need to restart Photoshop here. Just reopening the file makes it work again as well. Its a bummer for pipelines using the export from layers to png.
Photo of Kukurykus

Kukurykus

  • 664 Posts
  • 181 Reply Likes
I was saying of other bug noone mentioned in this theard what seems to be impossible. When you do 'Quick Export as PNG' from document with resolution other than 72 px/in what resolution layer is saved with? For me it's always 72, so that's bug?
Photo of Jeroen Hoekstra

Jeroen Hoekstra

  • 3 Posts
  • 1 Reply Like
Interesting point. Happens here too. Export is always 72dpi, however the amount of pixels is exact same size of the layer.
Maybe the intention was to make the quicksave to PNG always 72dpi?
But i see the logic of keeping the documents dpi settings in the export.
Anyone from Adobe has an answer?
Photo of Kukurykus

Kukurykus

  • 664 Posts
  • 181 Reply Likes
I'm not sure was that meant to always export .png's with 72ppi or that is bug. But it's logical to me as well it should keep original resolution. If not by 'Quick Export as PNG' then surely by 'Exoprt As...' (one item below in the same 'Layer' menu) where you have 4 formats to choose (incl. .png) where result of exporting is that files are getting 72ppi.

What is interesting I opened such exported image and compared with original and found that like you say, dimension (and quality) is still same. They differs only by number in resolution field. They look like new one had still the same resolution as original, but only was written with not coresponding number.

Perhaps they should look the same despite other resolution as far both got same dimension. You can do a test saving some layer with changed resolution to 72, but same dimension (simply change resolution to 72 in 'Resize Image' box and then change dimension values back to original ones before you click OK button). It will look the same as original.

Still you are right Adobe should say anything how that was designed, so we know is that bug, however I saw other topic where it seems it is. There is 'File / Generate / Image Assets' that is based on the same rule of exporting layers. All of the save with 72dpi. Users say it didn't happen in CC 2017, so some of them especially to have it working downgraded CC 2018 back to previous release.

I digged deeper and found in one of Photoshop folder file a note that Adobe is aware of this bug. So it seems engineers of 'Image Assets' couldn't do nothing as exporting layers functionallity was broken starting with CC 2018. My question is was if it worked also for 'Layer / Export As... or Quick Export as PNG' in CC 2017. That can be confirmed by someone who uses CC 2017 still. If layers were exported in that release with document resolution, then we can be sure it's a bug.

Here's related topic:

https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc-2018-generate-image-assets-doesn... 
(Edited)
Photo of Logan Venture

Logan Venture

  • 1 Post
  • 0 Reply Likes
Anyone know the latest status on this? I'm still having to reboot Photoshop to get Quick Export to work almost 50% of the times I try to use the function.

I haven't yet narrowed in on any patterns before it stops working, but usually it will last maybe 15-30min in a single session before suddenly the Quick Export function won't respond. I've tried changing Quick Export settings and clicking the button from menu vs layer / group with no luck.

I'm updated to the latest 19.1.5 release, 2018 MacBook Pro.
Photo of G H

G H

  • 1 Post
  • 0 Reply Likes
Same issue, neither 'export as' nor quick export is working. I was working on a series of documents for print and it is just one of the files that is rendering the export functions useless. I can sill open other files and export them properly while for this particular document it is not working. The documents I am working on are very simple, not containing any colors, not having a large number of layers. Just a few smart objects and a lot of text, which is basically the same for all the other documents.

I have tried restarting PS a considerable number of times and the problem still firmly sticks to this one file. I have looked into the 'save as PNG' solution, yet PNG is not supported in the dropdown menu - neither for the troublesome file, nor for healthy files.

The 'quick export' opens the explorer and lets me choose a filename, yet after hitting OK no file is being created. 'Export as' does not show the preview and the export button is dead.

I had looked at potential fixes, like resetting preferences, taking plug-ins offline (no plug-ins installed right now), and such - all to no avail...

Windows 10, latest version. 
Photo of Joe Muschinske

Joe Muschinske

  • 1 Post
  • 0 Reply Likes
Hi All, 
I've been trying to trouble-shoot this with Adobe for several months. Oddly my copy of PS CC 20.0.4 allows me to create the assets through Generator but retains the native res of the root file. Other's i know  do the same workflow but it does not retain the resolution - changes from 300dpi to 72dpi. Would love a fix/work around for this that is as efficient. I have no idea why it's working differently on my machine (adobe didn't know why either).