Photoshop: Puppet Warp overlap erases pixels under it around the borders

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
When you overlap part of the mesh when using puppet warp the mesh erases pixels below it with pixels that are empty. Empty pixels in the mesh should be transparent so that you can see the overlapped pixels below it and only the pixels being covered by other pixels should not be visible.

Photo of llama

llama

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
It looks like you have white pixels selected around your shape. If you're cutting pixels out of a while background the white pixels will show up like your example. If your shape is floating, and not cut out of white background you won't have this issue.
Photo of llama

llama

  • 3 Posts
  • 0 Reply Likes
The shape was on its own layer, the white pixels were transparent, but are wiping out what's under them and revealing the background below. Here is another screenshot showing it with the background turned off. I am also curious on how you got your mesh so tight to your object, when ever I shrink the expansion, it starts encroaching too far. On a side note, I'm also using nearest neighbor, and the pen tool.

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Can you post your files ( before and after ) on Creative Cloud or dropbox
Photo of llama

llama

  • 3 Posts
  • 0 Reply Likes
Yes, here is the link before the transform: http://adobe.ly/1okuwTi
And here is the link for after the transform: http://adobe.ly/1kDyvax

A quick note, when I turn it image interpolation to "bicubic automatic", this issue sort of goes away, but I need to use it with "Nearest Neighbor." Another note, if I make the drawing just a strait line by holding shift while drawing, it also doesn't have this issue.