Lightroom: Publishing to Facebook: Link application needed

  • 1
  • Question
  • Updated 7 years ago
  • (Edited)
I want to publish photos from LR to FB. When I to set it up in LR publishing manager, a box appears that says a link needs to be opened with an application. What application?
Photo of Tiki Nelson

Tiki Nelson

  • 2 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 114 Reply Likes
I would imagine that would be your default web browser.
Photo of Tiki Nelson

Tiki Nelson

  • 2 Posts
  • 0 Reply Likes
Initially, that's what I would have thought but here is the sequence of what happens. First, I click on Facebook setup from "Publish Services" menu. Then I click "Authorize on Facebook." That brings up a pop up that says to click "ok" to login to my Facebook account, follow the prompts and return to LR to complete the process. Once I click ok, two things happen: 1. my browser opens my facebook account and 2. the pop up appears requesting me to choose an application for the link to be opened.

My facebook account is already opened so why would I need to choose a browser application? For sake of argument, I entered firefox.exe as the application but when I click ok, the box doesn't go away so it is looking for something different.
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 114 Reply Likes
Could you post a screen shot of step 2 above? I'm wondering if the request for choosing an application is coming from Lightroom or your OS. I can't imagine that Lightroom would make such a request. If your browser opens with Facebook Authentication, that should be all you see, I don't see any reason for the question to pop-up. It may be something that can be ignored (press Cancel, assuming it's an option). Just authenticate in the browser window and go back to Lightroom.
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Facebook changes things around on their site frequently, and sometimes I've found it best to clear any previous authorizations on the FB side, then start fresh from LR.

On Facebook, try going into your Account Settings, then click on Apps (from the list on the left side of the page). If Lightroom is already there, remove it. Then, go back to Lightroom (cancel any of the pop up dialogs that you may still have open). Try authorizing on Facebook again, and see if it works.