Elements 14: Problem with 'add location'

  • 3
  • Problem
  • Updated 2 years ago
  • (Edited)
Just upgraded from PSE13 to PSE14 a few days ago.
The map is damn slow, not usable worst than before.
Worst, the add location button does not work, it opens a dialog that expects a text and accepts nothing...
Photo of Dominique MORICE

Dominique MORICE

  • 10 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 3
Photo of Surendra

Surendra, Employee

  • 168 Posts
  • 18 Reply Likes
Hi Dominique,
Please find my queries inline with your queries:
"The map is damn slow, not usable worst than before"
Its a bit surprising. Elements Organizer uses Google Maps for places view. So loading of maps depends entirely on your internet connectivity. Also there is no change in map loading workflow from PSE13 to PSE14. Requesting you to please run following test:
- Try to visit googlemaps.com and see if it loads fine.
- If you access to PSE13 on same machine, can you please do a comparative analysis in terms of time taken to load map.

"the add location button does not work, it opens a dialog that expects a text and accepts nothing.."
- Are you on Mac machine?
- Does the issue persists on relaunch of Organizer?
- Is it consistent? If so, is there any specific steps after which it occurs?
- When you are unable to type into 'add location' dialog, can you please try to input some text in search field in Organizer (provided at top right side) or into search field given on top of map shown in right panel.

~Surendra
Photo of Dominique MORICE

Dominique MORICE

  • 10 Posts
  • 0 Reply Likes
Hi Surendra

I fear I was not clear enough.

The map itself is coming normally, these are groups that are coming very slowly.
I have 30k+ localized pictures, it was still working with PSE13 but it kills PSE14.
Is there anyway to come back to basic pins with numbers as in PSE13?

Regarding the add location issue, it is consistent in media and map modes, my PC is running Windows7.
I will upload a screenshot.

Regards

Dominique
Photo of Dominique MORICE

Dominique MORICE

  • 10 Posts
  • 0 Reply Likes
Photo of Dominique MORICE

Dominique MORICE

  • 10 Posts
  • 0 Reply Likes
In previous post, the dialog box that I get when pressing 'Add Location'.
I can't capture it with the full PSE because it disappear as soon as I switch to another window.
Photo of Surendra

Surendra, Employee

  • 168 Posts
  • 18 Reply Likes
Hi Dominique,
"The map itself is coming normally, these are groups that are coming very slowly.
I have 30k+ localized pictures, it was still working with PSE13 but it kills PSE14. "
Thanks for the clarification.
If I am getting this correct then you are saying that map is loading fine at your end. It is just the (places) stacks that are loaded slowly. If so, then there is a change in behavior that in PSE14 we show stacks om Map. Also if you have hover on the stack and move your scroller than you can scroll through the images.
Given this behavior, it might be behaving a bit slow.

"Is there anyway to come back to basic pins with numbers as in PSE13? "
Sadly no. In PSE14, Organizer will always show Places stacks with images in it rather than simply showing the count. This behavior was changed after multiple requests from users for this behavior.

Regarding 'add location' dialog:
Are you able to type in the text? If so, what happens when you type?
As per design, user can type in text here and once done, user needs to press 'enter' key. Then Organizer will show Places suggestion for typed place. User can select any option and click on 'done/ok' button.
Please let me know if that is not working for you.

~Surendra
Photo of Dominique MORICE

Dominique MORICE

  • 10 Posts
  • 0 Reply Likes
Surendra,

I doubt any serious catalog even with only 10k elements can be displayed.
Personnally, I had to kill PSE after 20min (despite SSD and 8 GB of RAM) which is a pity as it was working with PSE13 .

You are right about 'Add location', it works by pressing 'enter' key.

Frankly, I really regret my upgrade to PSE14.
- I can't use the map anymore to display places where I took pictures (a bit slow...).
- I can't easily locate a set of pictures anymore as I used to do with PSE13 'add location', PSE14 'add location' does not allow to drop in the middle of mountains or fields only in named places.
- Also, there is no easy way to filter (using tags) in map mode to perform a grouped drop on the map (which I was doing with PSE13 'add location').

Being a professional software engineer too, I had a look on PSE database schema.
My 2 cents, I would suggest a table dedicated to geo info.

Thanks for your support,

Dominique
Photo of Dominique MORICE

Dominique MORICE

  • 10 Posts
  • 0 Reply Likes
Last comments on this topic.

I did one more try with world map displayed:
- 12 minutes to get the groups done
- Group location is weird in Europe, 2 groups covering each other making the second (biggest one) unusable (see picture)
- During map update 25% CPU max on a 4 cores system (lack of multithreading?)
- Once map is ready, every action is causing PSE to freeze which is the obvious result with big groups
- Honestly, for groups bigger than 0.5K pictures, pins shall be preferred
- It seems fully acceptable to have to zoom to get groups with pictures and it would make PSE a lot more reactive...

Regards,

Dominique

Photo of Dominique MORICE

Dominique MORICE

  • 10 Posts
  • 0 Reply Likes
Hi,

As PSE14 map was not performing so well, I gave a try with LR6.

LR is clearly too much for what I do (so I won't keep it), I just expect for a good organizer.
It is really a pity that LR displays all data on the map within a few seconds when PSE needs for several minutes (same catalog, same PC).

It is clearly a design issue on PSE side or a product management decision to make it a pain Inside PSE, in the latter case, it would be better not to offer that feature.

Regards,

Dominique
Photo of Dominique MORICE

Dominique MORICE

  • 10 Posts
  • 0 Reply Likes
Note for people who clicked having the same problem:
- One possible workaround is to select a given file directory
- It allows to get only pictures in that directory displayed on the map
- It allows to set/change/fix localization efficiently for a limited set of pictures
1) Set an approximate location using the dialog box (keeping in mind the poor ergonomy of that dialog ie that you need to press enter before anything happens)
2) Select map mode
3) Click on update in the picture group

I wrote a new post to question whether the same is possible with a selection of pictures (based on a tag).