Elements 10 keeps crashing - helps please!

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Elements 10. I am plagued by fault where the flag "Elements has stopped working" is raised. The screen goes grey then I am advised that Windows is searching for a solution -do I want to close down. The thing never cures itself and so I always have to shut PSE10 down and reboot it. Any thoughts most gratefully appreciated.
Photo of Derek

Derek

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
What OS version are you using?
Have you installed all the updates for Elements 10?

It sounds like you are using some version of Windows -- could you check for the detailed crash report in the system event viewer or the reliability reports and paste the details here? (we need the name of the faulting module)
Photo of Derek

Derek

  • 4 Posts
  • 0 Reply Likes
This is embarrassingly ridiculous Chris. I have found the report etc but can not for the life of me find a way of copy & paste onto this box. I have tried using the snip then paste, but no paste facility appears for this window. Likewise using Norton One Note.
I'm not much in learning new thing - I have a tough of dementia- can you guide me please.
Photo of Derek

Derek

  • 4 Posts
  • 0 Reply Likes


Finally made it!

The operating system is Windows 10 64bit.

Is the above OK?
Photo of helen Crouse

helen Crouse

  • 1 Post
  • 0 Reply Likes
I'm also trying to run PS Elements 10
I have an iMac running OS X El Capitan. I haven't used PS E in a while, and need to install software updates to run it, I believe? Where can I find them? On your website, the software update button takes me to this forum, but I can't anything for Elements 10 updates when I search for them here.

Please point me in the right direction!

Thanks.
Photo of Derek

Derek

  • 4 Posts
  • 0 Reply Likes
PSE10 can be updated by clicking on help. One of the options is update.