Elements 10: 'rolling back installation" and 'failed to install: Shared Technologies'

  • 2
  • Problem
  • Updated 1 year ago
  • (Edited)
I like many others (I've been on the internet) cannot load Photoshop Elements 10. I have also read about problems with 11 and 12. PROBLEM! When loading PSE10 I get the message 'rolling back installation" and 'failed to install: Shared Technologies'. I first ran into this the other day. I contacted support and went to a chat with Shevendra Singh who got lost trying to resolve the issue. She then dumped me by telling me I could get the fix on the forum site. At that point she quit all communications and didn't even communicate a 'bye' or some other exit. I did go to the forum site and saw quite a number of people with similar or same problem. I did not see many successes. I tried to find what is meant by 'Shared Technologies'. Couldn't even find an answer for that. I am frustrated and pissed and would like to the software loaded on my Sony laptop.
Photo of David Long

David Long

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
Hi David, Did you try this solution? https://helpx.adobe.com/photoshop-ele...
Photo of Gordon Pike

Gordon Pike

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled "The installation process has encountered an error while installing Shared Techno....

When trying to install Adobe Photoshop Elements 11 the following error message appears:"The installation process has encountered an error while installing Shared Technologies. Please restart your system and try again". Now what do I do?