Elements 14: Places Maps are very slow on Windows 10

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
Places Maps in Photoshop Elements 14 is so slow (zoom takes minutes) that's almost impossible to use. I installed on Windows 10. I had no problems with PSE 13 and Windows 10
Photo of Mauro Tala

Mauro Tala

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of Surendra

Surendra, Employee

  • 168 Posts
  • 18 Reply Likes
Hi Mauro,
Sluggish behavior wrt maps in PSE14 which is working fine in PSE13 is a bit of strange to me as PSE (both 13 and 14) uses GoogleMaps and hence map searching/zooming depends on the your internet connection.

Lets try to sort it out. Requesting you to please respond to following queries:
- The sluggish behavior you are observing, is it with places view only or with the entire Organizer application.
- Is the sluggish behavior is while loading places or if it is with zoom in/out places?
- What is the approx number of Places tag that you have in your places view/catalog?

~Surendra
Photo of Mauro Tala

Mauro Tala

  • 4 Posts
  • 0 Reply Likes
Sorry Surendra I miss your post. The problem is the same better described by Lukasz in the following posts. The slowness is due to thumbnails loading. Each zoom operation means PSE has to redistribute stacks in the map (more zoom in, more stacks have to be splitted in several near places), loading them again.
PSE 14.1 has lightly improved the situation, but the lag is still unacceptable.
My DB is 18K images, all of them have a place associated.
Mauro
Photo of Mauro Tala

Mauro Tala

  • 4 Posts
  • 0 Reply Likes
I didn't find a way to count how many different places I tagged; in the "places" tag tree there should be 250/300 entries.
Photo of Anthony Tracey

Anthony Tracey

  • 10 Posts
  • 3 Reply Likes
My map on Elements 14 running on Windows 10 is unusable. I have never experienced such a slow program. I really want a refund.
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like
Hi,

While I am not OP, I have the same problems. First observation is that the problem depends on catalog, not internet connection or Google Maps itself. With a catalog with 100 images, things are fast.
To answer your questions:
- Organizer works OK in Media or Events panel, but is really slow in Maps and sometimes a bit problematic with Faces (the latter has memory leak problem, reported by me in another thread).
- The slowness is already after opening Maps panel, when the displayed area contains pinned images. With a couple thousand of images in 10-20 locations it takes a couple of minutes to complete loading (I can measure it if you want). Zooming an panning are also very slow.
- I have approx 150 places tagged throughout the whole catalog.

OS is Windows 7 64-bit on Intel 3570K CPU with 8 GB RAM. I observe one core maximum load when the map is loading. Catalog converted from PSE 13 catalog, initial face recognition after conversion is complete.
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like
An addition:

I have confirmed that the slowness is related exclusively to catalog size in my case. I have created a catalog with 1300 images and movies (with face detection and GPS tags) and everything just flies.

So v14 gets a drastic performance hit in comparison to v13 with catalog like mine (35,000 images).
Photo of Surendra

Surendra, Employee

  • 168 Posts
  • 18 Reply Likes
Hi Lukasz,
Based on your inputs, let me refine the problem. The performance issue is not with loading maps but it is with loading pins. Am I correct here?

Also comparison of PSE14 Maps with PSE13 is incorrect technically.
Reason is: As you figured out the problem becomes apparent when catalog has a large number of media pinned on some locations. In PSE13, since we only used to show count of media and not the stack (or media thumbnail) hence PSE13 will be faster in comparison with PSE14.

Having said that, we understand that it is an issue and we are working on it.

~Surendra
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like
> Having said that, we understand that it is an issue and we are working on it. 

So, how the things are going with product change?
This is a big regression, as working feature has been made a non-working one for everyone with more than couple thousand of photos. That today means pretty much everyone.
Photo of Brian Evans

Brian Evans

  • 1 Post
  • 0 Reply Likes
I also would like to know when this is going to be fixed. I have upgraded from ver 10 to ver 14 thinking it would be good but its more like i have downgraded. trying to use face recognition or the maps function and the program is unusable as it is so slow.
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like
So, how things are going with fixing this?
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like
Hello,

Thanks for your answer.

Right, the issue is with loading pins, not maps themselves. By "maps" I meant the whole Places panel contents, including pins.

I understand a feature has been added (stacks with thumbnails shown). Simply, it is now very hard to use Places.

Regards,
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like
Hello,

By the way - why not enable using of the old "pins"? I, for one, don't see any gains from having image stack loaded in place of a pin.

Regards,
Photo of Lukasz Jakubowski

Lukasz Jakubowski

  • 28 Posts
  • 1 Reply Like
By the way again, in case when there are many closely-located spot you need to use maximum magnification to work, because stacks take much more place than pins. Regarding that any resize of map causes loading stacks anew (why???) which takes a couple minutes to complete, these makes Places in PSE 14 effectively a big regression for anyone working in Places with more than couple thousand of pinned images.
And I can't ever reposition freshly-added place.
Photo of Mauro Tala

Mauro Tala

  • 4 Posts
  • 0 Reply Likes
I agree with Lukasz. Having the thumbnail stack instead of pins makes the software useless without any gain in functionality. Who cares of thumbnails in a map ?
Photo of Peter Nordell

Peter Nordell

  • 1 Post
  • 0 Reply Likes
I find that Elements 14 runs well, but with a big catalog (55k photos) Places is unusable.  Loading takes several minutes, it is useless.  If the thumbnail stack creates a computational burden, I suggest we need the ability to turn that feature off.