Photoshop: How did I get a flattened PSD after saving PDF?

  • 28
  • Question
  • Updated 6 months ago
  • Answered
  • (Edited)
So I'm not going to rage. I really want to. But I won't. I'm using Photoshop CS 5.5 (Windows). I was on the sixth version of a high fidelity Website mockup. The client asked that I provide them the design in PDF format. So from within the .PSD file, I select "Save As" and choose PDF as the format. I complete the PDF wizard and all seemed good.

No. Apparently, when you save as a PDF, it turns the PSD file you actively have open into a PDF? I noticed that the file type changed to PDF from PSD on the tab. "That's stupid," I thought. "I'll just change it back to a PSD, since I've made a few modifications since I saved it last."

You know, in Dreamweaver when you execute a "Save As", it opens the new file in its own tab. Just a thought.

Maybe my next choice was wrong, but it seemed instinctive to me. I decided to "Save As" again, but this time as a PSD file. I still had my layers in tact, so I didn't think there would be a problem.

I close out the file. When I open the PSD file back up just a few minutes ago, it's COMPLETELY FLATTENED. GONE. MY WORK IS GONE. Awesome. Thank you.
Photo of Mason Shewman

Mason Shewman

  • 4 Posts
  • 1 Reply Like
  • frustrated

Posted 9 years ago

  • 28
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16852 Posts
  • 2825 Reply Likes
Official Response
I think there is some user confusion here. When you have a layered PSD, then choose File>Save As... and select PDF, and UN-check "Preserving Photoshop Edibility" the open file is not flattened at that point.

If you go back to the File menu, Save is disabled. You have to choose "Save As..."

When you do, the format is set to Photoshop PDF (Note that Save: "Layers" is unchecked with a ! warning symbol):

If I change the Format pop-up to "Photoshop" note that Save: "Layers" is still unchecked with a ! warning symbol:

If I save the file now, yes, the resulting PSD will not have layers. If you address the options/warnings, and check "Layers" then save the file, the resulting file will retain the layers.

Are you saying, that if you ensure that "Layers" is checked at this point and save the file the resulting file has no layers? I haven't been able to reproduce that.