Photoshop CC 2019: Artifacts after burning and dodging

  • 1
  • Problem
  • Updated 4 weeks ago
  • (Edited)
Created a pano in PS CC 2018 using 30 D850 files. Did some minior dodge/burns and started seeing large artifacts. What's going on here? I saved it to PSB, shut down PS, reopened and artifacts seem baked in. Can't use PS 2019 due to pano bug which refuses to blend. 

 
High Sierra, PS CC 2018, PS CC 2019
i7 8700K 6-core
64GB DDR4 3000
1TB NVME SSD (3.4GB/s)
Photo of seanhoyt-dot-art

seanhoyt-dot-art

  • 283 Posts
  • 45 Reply Likes

Posted 4 weeks ago

  • 1
Photo of Andrew Sender

Andrew Sender, Employee

  • 27 Posts
  • 11 Reply Likes
Hi Sean,
We are so sorry for your experience.  We are working on a fix for this issue.  By any chance are you working with Image -> Mode -> 16 Bits/Channel ? 

In the meantime, can you try enabling Preferences -> Performance -> "Legacy Compositing" checkbox and see if that fixes your problem?

 https://feedback.photoshop.com/photoshop_family/topics/color-error-when-flatten-image-photoshop-cc-2...


    Photo of seanhoyt-dot-art

    seanhoyt-dot-art

    • 283 Posts
    • 45 Reply Likes
    Actually, the artifacts showed up after downconverting from 16 to 8 and changing color space from prophoto to srgb. I was toying with lighting effects but cancelled and the artifacts remained and saved to psb.
    Photo of Andrew Sender

    Andrew Sender, Employee

    • 27 Posts
    • 11 Reply Likes
    Thanks Sean,
    That still fits the bug description we're hearing.  By any chance, did you try enabling "Legacy Compositing" to remove the artifacts?