Photoshop 2014 isn't working at all. Levels show no levels. Filters can't be applied. I'm at a loss. What should do!

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
I was trying to add a filter from the filter gallery and clicking okay did nothing. I went back to photoshop CC and lo and behold, the filter had been applied, but I couldn't see it in 2014.

I wanted to apply levels to a photo but opening up levels doesn't show any values.

The whole program is just one hot mess. What is the fix? Who do I call? Customer support often involves more than two hours. I'm at a loss.

Please help.
Photo of Cynthia Fink

Cynthia Fink

  • 1 Post
  • 0 Reply Likes
  • Frustrated.

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
What OS version are you using?
Have you updated your video card driver from the GPU maker's website?
Do you have any third party plugins installed? If so, have you tried disabling them?
Photo of Cyndi25

Cyndi25

  • 1 Post
  • 0 Reply Likes
I'm using Windows 8.1.
I just updated the drivers on my NVIDIA graphics card GeForce 9400 GT less than two weeks ago.

NIK Collections and Topaz Labs show up on Photoshop CC but they don't show up on Photoshop 2014.

How do I disable them?

Here's another odd thing. I was working on the photo I described using the filter gallery where I clicked ok and nothing happened, however, when I opened up Photoshop CC, in fact the changes had taken place, even though I couldn't see them in PS 2014. Isn't that weird?

It seems weird to me.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
That sounds like the symptoms of a video card driver bug -- check back with NVidia for updated drivers.