PS7 under W10 won't recognize my Twain device

  • 1
  • Question
  • Updated 2 years ago
PS7 under W10 won't recognize my Epson V850 Pro scanner as a Twain device. When I try doing an "import" sometimes the Epson logo comes up and disappears and several minutes later Windows tells me PS is "not responding" - other times PS tells me it cannot find the scanner at all. My W10 is Microsoft's upgrade from my original W7, I've tried reinstalling PS7 (and the 7.0.1 update) with no help, also the Epson utilities. The scanner itself works fine using its own software and I can move the resulting jpegs into PS7, so I'm not stuck, but just wondering if there's a way to get PS7 to recognize the scanner directly as it has always done for me in the past (since XP).
Photo of Georges Gutman

Georges Gutman

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Are you using Photoshop 7 or Photoshop Elements 7? Do you have the TWAIN plug-in installed? Is your scanner driver compatible with Windows 10?
Photo of Georges Gutman

Georges Gutman

  • 2 Posts
  • 0 Reply Likes
Sorry about my late reply...

I'm using Photoshop 7, not Elements.
My scanner works fine with its own software, so the driver must be W10 compatible.

As for a Twain plugin, I didn't separately install one when I switched to W10 and reinstalled PS7.
I just tried installing one that I downloaded from here:
https://helpx.adobe.com/photoshop/kb/twain-scanner-plugin.html
but with no apparent success, I double-clicked on the "Twain_32.8BA" file but all that happened is that it opened my PS7 program.

But again, the behavior when I try using "Import" within PS7 is that the Epson logo appears for a few seconds then disappears, then the little "progress" circle spins for a few minutes until it times out and tells me PS7 is not responding. So my guess (for what it's worth!) is that the absence of a Twain plugin is not the issue.

George