Photoshop: Polygonal Selection tool marching ants don't deselect with ctrl + d (Win 10)

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
When making a selection with the polygonal tool the command on a PC of 'Ctrl D'  does not get rid of the marching ants.
I'm running Windows 10 on a PC
Photo of David N Moorhouse

David N Moorhouse

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Howdy David,

You're talking about the Polygon Lasso Tool, right?  What happens when you press CTRL+D?  If you do CTRL+A and then CTRL+D, does it work?  What about working with other kinds of selections?  Could you have changed your keyboard shortcut?  I just tired it a moment ago on Win10 and everything worked fine, so I'm wondering if there's anything particular about your setup.  What is your keyboard set to?  

Thanks,
David
Photo of David Moorhouse

David Moorhouse

  • 4 Posts
  • 1 Reply Like
Hi David,
If I select a whole image by using Ctrl A the marching ants will disappear OK. If I use the tool & make an irregular polygon selection, then press Ctrl D to remove the marching ants they are removed from the image but any of the selection which is outside the image i.e on the background, they remain on screen. I have attached a screen shot to indicate what I mean.
Just to demonstrate, here I have made an irregular selection, then pressed delete to remove the parts of the image selected then pressed Ctrl D to remove the ants. As you can see the ants have stayed on the background, hope this helps.
Windows 10 & normal extended keyboard is what I use. This phenomena is not present in Adobe 15.5 on my machine. I'm running an i5 proc with 16 MB RAM
Cheers
David
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Howdy David,

I'm wondering if this might be an issue with your video card.  Could you try going to Preferences > Performance and turning OFF Use Graphics Processor in the upper right-hand corner.  Relaunch Photoshop and see if things are better.  Either way, I'm curious of the results.

Thanks,
David
Photo of David Moorhouse

David Moorhouse

  • 4 Posts
  • 1 Reply Like
Hi David,
When I checked my GPU it was unchecked. I had Adobe support on my PC last week when PS 17 would not shut down & I think they turned it off. It's on now & seems to have solved the problem. So you were spot on with that, thanks for your help.
Cheers
David