Photoshop CC 2018: Batch: "Could not complete the Batch command because the file could not be found."

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
Batch action has worked before on the same Windows 10 PC, now does not.  I create an action (In this case, it is 'resize, save, close'). I've used this type of action before.  Files are .jpg. I have also just updated PS CC 2018 and Camera Raw CC (problem before and after updates). Then, automate --> batch, all open files, named the destination folder.  Click "OK", then get this error message: "Could not complete the Batch command because the file could not be found." I have changed various settings in batch options and get the same result. What file is this error referring to?  I asked it to act on all open files. Please assist.
Photo of Vicky Thomas

Vicky Thomas

  • 1 Post
  • 0 Reply Likes

Posted 8 months ago

  • 1
Photo of Eduardo Moura

Eduardo Moura

  • 6 Posts
  • 7 Reply Likes

I just had this error and found out that the Log Error option was the culprit. I checked my Batch options dialog (from Bridge) and they were like this:

Errors: Log Errors to File

Destination: None 

We need to specify the folder (destination) where Ps should write the error log file, otherwise it can't run the batch. That's what Photoshop was complaining about. If you're thinking the error message was way too cryptic, you're not alone. It took me a long time to figure this out.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15339 Posts
  • 2228 Reply Likes
I can't figure out how to get in this state where the destination is none. I always get a warning that a destination must be set for the log file when I click [OK] to run the batch. Are you running the current versions of Photoshop and Bridge?
Photo of Tunde McDonald

Tunde McDonald

  • 1 Post
  • 0 Reply Likes
Thanks a Mil Eduardo, I told it Untitled.txt to be saved to the desktop and it's working fine now