PS CC 2017 Eyedropper in 'current layer'mode selects only gray colors. Please Help!

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Hi Everyone!

I am currently facing a color picking issue that is hampering my work.

Activating the eyedropper in 'current layer' mode and 'sample size : Point sample' selected, the eyedropper picks up only the value (i.e gray tone) of the color and not the hue.

How is it triggered?
1. Have a normal layer with your color on it.

2. Activate 'current layer' and 'point sample' in eyedropper settings.

3. Make a hue/saturation adjustment layer , desaturate the adjustment layer completely.

4. HIDE the hue/saturation layer. Activate your normal color layer and pick the color with the eyedropper.

Result is a gray color. Attached is a screenshot. Selecting the pink results in a gray color selection.




Deleting the adjustment layer doesn't change the gray color picking.
This issue is found only when eyedropper is in 'current layer' mode. All other 'layer modes' of the eyedropper work well.

Restarting PS delays this issue for a while. So does deleting the preferences on starting PS.
Resetting the eyedropper tool doesn't change anything.

Please help as I would love to get back to work as soon as possible. Thanks!
Drake
Photo of drake

drake

  • 2 Posts
  • 1 Reply Like

Posted 2 years ago

  • 1
Photo of Tom Attix

Tom Attix, Employee

  • 42 Posts
  • 15 Reply Likes
Hi Drake-

I can't get this to happen, does it happen immediately or after using the Photoshop for a while?
Also, which version of Photoshop are you using and what are your GPU settings (Preferences/Performance)?

Thanks
-Tom Attix
Photo of drake

drake

  • 2 Posts
  • 1 Reply Like
Hi Tom,

It happens after using Photoshop for a while and even sooner if I use the hue saturation adjustment layer as mentioned in the steps in my first post. It happens on PS CC 2015 as well as PS CC 2017. At the moment, I am forced to delete the preferences and restart photoshop everytime it happens. This helps for sometime and the issue shows up again.

I have also tried it on my friend's laptop that runs PS CC 2014 and this issue occurs in the laptop too.

I have tried various GPU settings from basic, normal and advanced and tried disabling the GPU settings by unchecking the 'use graphics processor' but it made no difference. At the moment its on 'Advanced'.

I'd really like to get this sorted. There have been people having the same issue (or similar) but no solutions yet.
https://forums.adobe.com/thread/991306

https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc-2017-eye-dropper-displays-wrong-...

Thank you for your time!