Photoshop CC 2015: Corrupting images?

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
So, I'm getting a very frustrating problem when trying to import some adjustment layers from one psd file to another.



It appears that the file becomes corrupted.

This seems to be a common problem amongst other users too but is being brushed off as an Apple OS 10.10 issue. I am using a "stable" MacOS 10.9.5 but am having the issue too.

Other users have reported similar problems, possibly occurring when using gaussian blur, smart objects etc. I too have these layers and objects in both files and am having the same problem.

This was suggested in another post but has not helped.



PS CC is up to date.

So whats the problem and how can I fix it?

Ps... I have tried the files in PS CC 2014 and get the same result?
Photo of Anthony ORourke

Anthony ORourke

  • 2 Posts
  • 0 Reply Likes
  • really annoyed

Posted 3 years ago

  • 2
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Hi Anthony,

Sorry if you feel the issue is not getting the attention it deserves.  It appears, however, to be an issue with the graphics processor of a number of video cards and is NOT tied to a specific release of Mac OS.  This is something that needs to be fixed on a far more basic level than applications operate.  As a result, there's not much the Photoshop team can do to resolve it.

Have you tried all four of the steps in the link you posted?  If those don't work for you, I'm happy to follow up, preferably via a web-hosted screenshare, so I can see your machine and settings live.  Your issue may indeed have a different origin than the "regular" black-and/or-white squares bug.  Please let me know.

Thanks,
David
Photo of Padzilla

Padzilla

  • 21 Posts
  • 4 Reply Likes
Did you have any success with making this problem go away?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14141 Posts
  • 1765 Reply Likes
Based on the date, this was occurring with CC 2015.0. Let us know if you're able to reproduce with CC 2015.1.2. Thanks.
Photo of C G

C G

  • 2 Posts
  • 0 Reply Likes

I had strange vertical banding in Photoshop CC 2014. I updated to Photoshop CC 2015.5.1. 

Now my layers are broken up into strange mosaics, even the ones that are turned off.

It happens after I turn a layer into a smart object and then apply a filter, but not every time.  When I go backwards in the History panel, the problem is still there. If I close the file without saving and reopen it, the problem is still there.

My files are on an external drive. I ran both Disk Utility and Seagate’s External drive diagnotics on it– my drive passed. I’m working on both an iMac and a MacBook Pro. Both operating systems are El Capitan. The problem happens with both computers. When I open Photoshop I skip loading optional and third party plug-ins. The problem is there whether you zoom in or out.

For now, I’m working on copies of files and not using smart objects.

I would really appreciate your help. Thank you very much.