Photoshop 21.1: Every drawing action (Painting/selections) snaps to upper left hand screen corner (Windows 7/Window 10 with WinTab)

  • 61
  • Problem
  • Updated 2 weeks ago
  • In Progress
  • (Edited)
Image: https://d2r1vs3d9006ap.cloudfront.net/s3_images/1825638/RackMultipart20200219-10082-123vxlm-problem_...
This problem is reproducible with every start of Photoshop and persists.

It started to appear today with the new update to 21.1

In almost all drawing tools (brush, pen, smudge, copy, eraser, etc...) , after i click and drag a little to draw something, the tooltip will snap to the upper left hand corner of the screen space, (drawing a line to there).

 - this is version 21.1 of creative cloud photoshop in Germany, also tested in english install, and switched to english locale, on windows 7 64 bit

- I tried resetting Photoshop to defaults (CTRL-SHIFT-ALT-Start)

- I tried resetting all tools to default via tool palette

- i tried resetting all brushes to defaults

- i tried restarting computer

- i tried disabling all other programms running (autohotkey, browser, mail-programs)

 

Hints are:

- if in brush i turn up "Smoothing (Glättung)" to something higher than 0% then the bug will not occur.

- the bug will only occur if a click-and-drag. Doing just clicks, it won't jump to the corner. Someone else with the same problem reported he also has the problem with clicks too, not just just with click-dragging-and-releasing (a.k.a painting)

- the tools that have no smoothing-% setting, i can not get to work.

 



There is a thread about this on the adobe support community forum:

https://community.adobe.com/t5/photoshop/bug-every-drawing-action-snaps-to-upper-left-hand-screen-co....



Other people have posted about a seemingly similar problem on the adobe support community forum.

https://community.adobe.com/t5/photoshop/bugs-in-v21-1-0/td-p/10933438?page=1

https://community.adobe.com/t5/photoshop/brush-tool-lasso-tool-snaps-up-to-the-corner-when-using-a-m....



My SYSTEM:

Adobe Photoshop Version: 21.1.0 20200212.r.106 2020/02/12: 4dd027efb58  x64
Anzahl der Starts: 1
Betriebssystem: Windows 7 64-Bit
Version: 7 SP1  6.1.7601.24545
[System Info truncated by moderator]
Photo of Stephan Möbius

Stephan Möbius

  • 3 Posts
  • 1 Reply Like

Posted 1 month ago

  • 61
Photo of Peter A

Peter A

  • 1 Post
  • 0 Reply Likes
Same problem. When making any selection it spikes up to the  left corner.
Windows 7, GTX 1080ti, Razer Abyssus v2 mouse
Photo of Dave Jones

Dave Jones

  • 2 Posts
  • 4 Reply Likes
Any more word from the engineers??? This has been going on for almost a week now.

(are we going to get a refund for our CC subscription for all the days that Photoshop is effectively useless??)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16620 Posts
  • 2706 Reply Likes
Roll back to 21.0.3 if you’re struggling with 21.1. Instructions here: https://helpx.adobe.com/download-inst...
Photo of Dave Jones

Dave Jones

  • 2 Posts
  • 4 Reply Likes
There's nothing there about how to retain preferences and brushes, etc... which according to other posts are all lost when you revert to a previous version.
Photo of Pete Green

Pete Green, Customer Advocate

  • 765 Posts
  • 153 Reply Likes
Hi Dave, 

When choosing to install a previous dot release version of an App, it does uninstall, prior to reinstall, and strangely does not give you the option to keep your preferences in the dialog performing the revert this way. Here are two ways you could retain your preferences.

1. Uninstall first, then Install 21.0.3 -- From CreativeCloud Desktop, choose to Uninstall Photoshop 21.x, and choose to KEEP your preferences on the first uninstallation dialog. 



This would stop the removal of your preferences during uninstall so when you reinstall 21.0.3, the preferences would remain. 


2. Manual backup of your preferences: You can make a manual backup of your preferences and brushes by copying their enclosing preferences folder. Locations of specific Ps preference files are here: https://helpx.adobe.com/photoshop/kb/preference-file-names-locations-photoshop.html

The Tl;Dr on that article for Windows is: Most preferences are stored in the following folder: %appdata%/Adobe/Adobe Photoshop [version]/Adobe Photoshop [version] Settings

Make a backup of that incase of any fear of lost brushes/preferences/etc, copy them back into the same location upon install of previous/other version.

Let us know how it goes.
Regards,
Pete
Photo of Josh Langley

Josh Langley

  • 3 Posts
  • 3 Reply Likes
Guess that means "no" for users getting a refund for the software that doesn't work, which our jobs rely on, that we're perpetually paying for.
Photo of Randy Griswold

Randy Griswold

  • 2 Posts
  • 1 Reply Like
Same issue here, seems to be that this was clearly a "beta" release and if so it should have stated this, I recently jumped back on the Photoshop CC subscription wagon, and almost immediately having these kind of issues.


Photo of Pretzel

Pretzel

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Clone Stamp Tool: jumps to upper left corner after releasing the stamp.

Hello! I've been using Photoshop for years and recently installed the latest version on a new computer. However, the clone stamp tool is not working like it used to.

Almost every time I've tried to use the tool, the cloning jumps into the upper left corner. See the example below:




Point 1: This is where I'm cloning by ALT + CLICK. This works fine.
Point 2: This is where I start to stamp by left-clicking and dragging rightwards. This works fine too.
Point 3: This is where I release the click and want the cloning to stop stamping, but the moment I release, a line going diagonally up/left appears and stamps along the line.

Does anyone know how to fix this? Here's a list of things I've tried to no avail:
- restarting my computer
- uninstalling/reinstalling Photoshop
- resetting the tool
- resetting the preferences

My clone stamp setting are normal and set to the current layer.

If anyone knows what's wrong with Photoshop or what I did wrong, your help would be much appreciated! This is driving me crazy because it used to work fine before and I couldn't find a thread with this issue :(

Thank you!
Photo of Benjamin Weiler

Benjamin Weiler

  • 22 Posts
  • 6 Reply Likes
I know, this has been said before, but please, please: unbreak this. Preferably fast. These breakages in functionality have made me abstain from updates for at least 6 months after initial release for the last 5 years. This time, I was trying to fix another bug in PS 2019. Instead, I got this. I am a little displeased.


Photo of CristianC25

CristianC25

  • 58 Posts
  • 25 Reply Likes
I'm having the same issue on a newly installed Photoshop 21.1, I don't have any other version to make a roll back to since it's a new Windows 10 install. How can I install an older version of Photoshop which doesn't have this brush stroke bug?
(Edited)
Photo of CristianC25

CristianC25

  • 58 Posts
  • 25 Reply Likes
I have read the above comments on page 1 and have installed an older version of Photoshop which does not have this bug. Hopefully you are not ignoring this bug and fix it soon.
Photo of Frogger

Frogger

  • 21 Posts
  • 9 Reply Likes
Windows 10 since Photoshop CC v21.1.0  now whenever I use mouse to draw a lasso shape, it always snaps to top left. This is regardless of what shape and how carefully I am closing shape. Makes this version unusable. Tried resetting tools, preferences  etc. Need urgent fix. However the clone stamp rotate preview is broken in the previous version. PLEASE get sorted ASAP.




Photo of Frogger

Frogger

  • 21 Posts
  • 9 Reply Likes
I should have added that I have added PSUserConfig.txt with "# Use WinTab
UseSystemStylus 0" in to overcom problems with Wacom pressure settings. The wacom Pen use with Lasso tool works. Removing the file is not an option as I need the pen sensitivity !! I hope this info helps to a very quick fix.
All was OK with v21.0.3 except clone stamp preview AFAIK
(Edited)
Photo of Sophii Maria

Sophii Maria

  • 1 Post
  • 0 Reply Likes
I have just come back from vacation and noticed this issue also. Photoshop is unusable in this update. Windows 7 user also. Will roll back to previous version. 
Photo of aaron knutson

aaron knutson

  • 1 Post
  • 0 Reply Likes
I am having this same problem. Adobe, please fix! Adobe Photoshop V.21.1 on Windows 7. Rolling back...
Photo of Ivaylo Petrov

Ivaylo Petrov

  • 2 Posts
  • 0 Reply Likes
The same issue here since yesterday. Using brush tool, healing brush, selection tool, when make just little movement and release the mouse all snaps to the left up corner. Was trying different mouse but still have the same issue. When  I using Wacom tablet pen- no issue- everything works fine.Using Windows 10 up to date, Ge Force 1060.
Photo of Ivaylo Petrov

Ivaylo Petrov

  • 2 Posts
  • 0 Reply Likes
Today issue is fixed. Don't know how this happened. Just after Windows auto update today  morning I am trying to work in Photoshop V.21.1 and everything works flawlessly!
Photo of DaveG

DaveG

  • 1 Post
  • 0 Reply Likes
After reading Ivaylo Petrov's comment saying that this is fixed, I reinstalled  v21.10 but I discovered that the problem IS NOT FIXED.... (March 14th 2020)
Photo of BWW

BWW

  • 3 Posts
  • 2 Reply Likes
Adobe needs to go back to quality control and beta testing before releasing updates, like they did with the Creative Suites releases.  Now they're seem to be rushing updates out to justify the reason for switching to a subscription based system.  Yes I like to get updates and upgrades whenever they get released, but only when they are thoroughly tested and ready for release.
Photo of Simon Fisher

Simon Fisher

  • 1 Post
  • 0 Reply Likes
Same here! It creates shooting lines when i lift my pen and my pressure sensitivity does not work with windows ink. I can't draw and am using Affinity Photo now
Photo of Gabriele Correddu

Gabriele Correddu

  • 10 Posts
  • 0 Reply Likes
I would like to +1 this - however, this issue appears to be intermittent on my device (although, it's been rather persistent today, prompting me to reach out).

I've also noticed that by setting the Smoothing setting to ≥1%, the issue disappears on the Brush-based tools.

However, the issue is affecting every tool if performing a drawing action, including all Selection tools, even in other workspaces like the Content-Aware Fill window. This is mighty annoying, please fix!
Photo of RANDY LESLEY

RANDY LESLEY

  • 1 Post
  • 1 Reply Like
I too am having the same issue. I just updated and now this. It would be nice if Adobe would at least warn people there is a problem before they proceide with the updated. 

Just curious how will we know when this has been corrected so we can return to the 2020 version?
Photo of Dave Grainger

Dave Grainger

  • 15 Posts
  • 2 Reply Likes
Every software maker is facing a problem, which is this: (1) code is so vast and (2) there is a near infinite variety of combinations of hardware / other installed software out there that it is virtually impossible for any company to be able to test their stuff on all possible sets of combination of hardware, software environment, use to which the program will be put...
Photo of BWW

BWW

  • 3 Posts
  • 2 Reply Likes
That's what beta testers are for.  What you say is true, but the same bug on multiple tools that was quickly caught by all Photoshop users should have never left the programmer's offices.
Photo of Dave Grainger

Dave Grainger

  • 15 Posts
  • 2 Reply Likes
If one could get an infinite number of Beta testers, would THEY be able to write Shakespeare or find an piece of errant logic in the window of time before a product has to go to the market? I dunno: ask Boeing about that.
Photo of Dave Grainger

Dave Grainger

  • 21 Posts
  • 7 Reply Likes
The release of V 21.1.1 announced yesterday seems to have fixed this problem for me. I did have a tussle with error messages relating to Adobe Temp files when trying to Upgrade, wound up Uninstalling, deleting the Adobe Temp directory on C: and the a hard reboot, after which a fresh installation worked. (I suspect those temp files might have been hold overs from a CS6 version that I uninstalled last fall....)
Photo of Gabriele Correddu

Gabriele Correddu

  • 10 Posts
  • 0 Reply Likes
I see - the list of fixed issues does not mention this, so I don't think this has been acknowledged yet. I'll hold off for another version or two, I think...
Photo of Dave Grainger

Dave Grainger

  • 21 Posts
  • 7 Reply Likes
I noticed that too, but have seen other comments indicating that it is fixed. I installed and have been using it all morning  without a problem.
(Edited)
Photo of CristianC25

CristianC25

  • 58 Posts
  • 25 Reply Likes
I also tested the brush tool and clone tool for 15 minutes, it worked well. The problem didn't appear after the last update. I hope it is fixed for now.
Photo of JJMack

JJMack

  • 222 Posts
  • 40 Reply Likes
Still have a problem using Wacom tablet pen with WinTab interface with Photoshop 21.1.0  and 21.1.1.   INK is not Issue free and INK is not supported in old Photoshop versions.  WinTab support is required,
Photo of Paul

Paul

  • 13 Posts
  • 3 Reply Likes
21.1.1 fixed the issue for me too.
Photo of JJMack

JJMack

  • 222 Posts
  • 40 Reply Likes
The problem seems related to the Wacom Pen rocker button configuration if I disable the lower setting I do not have a problem in 21.1.1  in 21.1.0 even if  I disable that button I had flaky problems.  Normally I set that button to Alt+Right Click and that not Problem in 21.0.3.   In 21.1.1 with that set to Right Click its default or my settings I have flaky problems in 21.1.1 
Photo of Stephan Möbius

Stephan Möbius

  • 2 Posts
  • 1 Reply Like
I can confirm that the update to 21.1.1 fixed the jumping tools for me.
Photo of Phillip Turner

Phillip Turner

  • 22 Posts
  • 2 Reply Likes
This reply was created from a merged topic originally titled Bug with brush jumping to 0,0 if using a mouse and smoothing is at 0%.

When using a mouse to paint, there is a jump to 0,0 (screen, not document) when I release the mouse button. This leaves a line on the document. This only happens with a mouse when the smoothing is at zero percent.
I do not see the problem with a pen/tablet, OR when smoothing is > 0%

The clone and smudge tools do not have a smoothing setting so they show the problem all of the time with the mouse (but not with a pen).

Desktop PC - AMD processor with old Graphics card. Acceleration on or off makes no difference.
Windows 10 (1909). Photoshop CC 21.1.0 (tested on PS CC 20.0.8 on same PC - no problems found)
Tablet = XP-PEN G640S .... I have replicated the problem with the tablet removed (but the drivers were still loaded)