Photoshop 19.1.2: Still has brush delay

  • 1
  • Problem
  • Updated 3 weeks ago
  • (Edited)
I'm not sure when it started but whenever I use the brush tool there is a workflow killing lag as the brushstrokes on screen struggle to catch up. What is going on?  I read earlier about there being some issue with smoothing but no matter what I do it persists.
Photo of edward.caruso

edward.caruso

  • 152 Posts
  • 41 Reply Likes

Posted 2 months ago

  • 1
Photo of Adam Jerugim

Adam Jerugim, Employee

  • 192 Posts
  • 82 Reply Likes
I'm curious what your hardware is where you're seeing the delay (including the GPUs) and how many displays you have running. If you are using multiple displays, is PS running on the primary or secondary display?

A couple of things to try:
1.  Go to Preferences > Performance > Graphics Settings and click the Advanced Settings button. From the drop down options, change it to basic (if that doesn't help, try disabling GPU altogether).
2.  When painting, hide all open panels (by hitting the Tab key)

Do either of the above changes help with overall brush performance?

Thanks,
Adam
(Edited)
Photo of edward.caruso

edward.caruso

  • 152 Posts
  • 41 Reply Likes
I'm on the 2017 iMac, 4.2 Ghz, 64GB RAM, 8GB GPU, main image on the iMac, palettes on the 2nd monitor.
I've been using it on advanced GPU since I've bought it this fall, only recently it seems to be lagging, so it must be a recent PS update. 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
Can you tell Adam whether either of the trouble-shooting steps improve painting or not? That might give him the clues he needs to help solve this issue for you.
Photo of edward.caruso

edward.caruso

  • 152 Posts
  • 41 Reply Likes
Yes after even disabling the GPU, painting is still lagging. Same with hiding tabs. 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
For #1 - Basic also didn't have any effect? (Note: you have to close all documents for this change to take effect)
For #2 - just to confirm, you hid all panels, correct? (You mention tabs, so not sure if you've simply disabled document tabs)
Photo of eartho

eartho

  • 740 Posts
  • 182 Reply Likes
What is your Smoothing setting in the options bar?
Photo of William Chitham

William Chitham

  • 10 Posts
  • 1 Reply Like
Same issue on a Win10 64bit machine, Nvidia Quadro 4000 graphics. I've tried the fixes mentioned here without succcess and hoped 19.1.2 would fix it but was disappointed. Tried them again today, still no joy BUT then I went to the advanced tab and enabled "Use Open CL" and voila - no lag. Then I disabled "Use Open CL" - still no lag. In fact I tried more or less all the combinations of Graphics Processor settings and couldn't provoke the lag. Then I started writing this post, went back to PS to check something and the lag is back and the Open CL trick doesn't work. ARGGHH!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13932 Posts
  • 1653 Reply Likes
Wow. That's very strange behavior. Seems to indicate some sort of graphics card issue/conflict. Did the computer ever sleep? If you look in the system info, is there anything about a driver crash?
Photo of edward.caruso

edward.caruso

  • 152 Posts
  • 41 Reply Likes
Which driver would I be looking for? Is this not a memory leak?
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13932 Posts
  • 1653 Reply Likes
It will show up something like this in the system info (Launch Photoshop and select Help > System Info... )

Image cache levels: 4 
The GPU Sniffer crashed on 8/19/2017 at 7:19:39 PM 
OpenGL Drawing: Enabled. 
Photo of Adam Jerugim

Adam Jerugim, Employee

  • 192 Posts
  • 82 Reply Likes
Another data point would be helpful here: does the lag happen as soon as you start working on images in Photoshop or does it get worse over time?
(Edited)
Photo of edward.caruso

edward.caruso

  • 152 Posts
  • 41 Reply Likes
It definitely gets worse over time. I'm going on normal GPU now, it was brushing ok this morning, then got progressively worse. Quitting the program and reopening doesn't help.
Photo of William Chitham

William Chitham

  • 10 Posts
  • 1 Reply Like
I'm not certain. I haven't noticed it progressing but to be honest as soon as it happens CC2018 becomes unusable so I bail out and go back to CC2017 which works fine.
Photo of Adam Jerugim

Adam Jerugim, Employee

  • 192 Posts
  • 82 Reply Likes
Edward, can you try CC 2017 and see if the lag is present there as well? That would be very helpful to know. Thanks.
Photo of edward.caruso

edward.caruso

  • 152 Posts
  • 41 Reply Likes
I went back to PS CC 2018 v19.0 and so far I do not see a big lag, but not 100% certain. I do not think the lag started that long ago so I don't think going back to CC 2017 is necessary.

Unfortunately after downgrading to v19.0 from v19.1.2 it deleted all of my workspaces and settings. Luckily I was able to restore everything from my boot drive backup.
Photo of eartho

eartho

  • 730 Posts
  • 179 Reply Likes
have you tried lowering the Brush Smoothing settings?
Photo of Craig White

Craig White

  • 13 Posts
  • 1 Reply Like
Has anyone tried the 19.1.3 release? I downgraded to 19.1.1 (from 19.1.2) because of the brush lag bug... I'm curious to update to the latest release, but don't want to go through the hassle of downgrading again (losing my workspaces, brushes, etc.)

I'm back to the sticky cursor bug version 19.1.1 ... ugh.
(Edited)