Problems with Photoshop CC2014 and my graphics card.

  • 1
  • Problem
  • Updated 4 years ago
I just updated to PS cc2014 today. It's having problems with my graphics card ( Nvidia GeForce GT 750M - brand new). I do a lot of panoramas, and it disables the GPU when it loads. To do adaptive wide angle filter, I have to turn on the GPU. The program closes when I try to do a Puppet warp afterwards (and turns off the GPU).

If I go back to Photoshop cc, it works fine with the graphics card. But the update to Lightroom 5 uses Photoshop 2014 by default.
Photo of Kurt Eakle

Kurt Eakle

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Is Photoshop telling you why the card is being disabled?
What does Help->System Info say about the GPUs?
What OS version are you using?
Photo of Kurt Eakle

Kurt Eakle

  • 3 Posts
  • 0 Reply Likes
The first time it loaded it said I needed to update the driver for my graphics, so I went to the Adobe GPU page which linked to Nvidia and had a new driver for the graphics card. Installed the driver, rebooted and tried again. Still didn't work.

If I go from Lightroom to CC2014 with a panorama

1) with use GPU set on in preferences - program stops with message
"Adobe Photoshop CC 2014 has stopped working" close program

Close CC2014 - retry launch from LR. Get message

"Photoshop has encountered problem with the display driver and has temporarily disabled enhancements which used the graphics hardware.

Check the manufacturer's website for latest software
etc."

Double check Nvidia site - driver is the latest version (337.88)

????

2) If I manually load the same photos into Photoshop CC 64, it will use the graphics
cpu and make the panorama

???

I'm running Windows 8.1. New HP Envy laptop w/ i7 cpu // 16 gb RAM // Nvidia GeForce GT 750M w/ 2 gb ram.

System info says:

glgpu[0].GLVersion="3.0"
glgpu[0].GLMemoryMB=2080
glgpu[0].GLName="Intel(R) HD Graphics 4600"
glgpu[0].GLVendor="Intel"
glgpu[0].GLVendorID=4318
glgpu[0].GLDriverVersion="10.18.10.3277"
glgpu[0].GLRectTextureSize=16384
glgpu[0].GLRenderer="Intel(R) HD Graphics 4600"
glgpu[0].GLRendererID=4068
glgpu[0].HasGLNPOTSupport=1
....

clgpu[0].CLPlatformVersion="1.2 "
clgpu[1].CLPlatformVersion="1.1"
clgpu[0].CLDeviceVersion="1.2 "
clgpu[1].CLDeviceVersion="1.1 CUDA"
clgpu[0].CLMemoryMB=1784
clgpu[1].CLMemoryMB=2048
clgpu[0].CLName="Intel(R) HD Graphics 4600"
clgpu[1].CLName="GeForce GT 750M"
clgpu[0].CLVendor="Intel(R) Corporation"
clgpu[1].CLVendor="NVIDIA Corporation"
clgpu[0].CLVendorID=32902
clgpu[1].CLVendorID=4318
clgpu[0].CLDriverVersion="10.18.10.3277"
clgpu[1].CLDriverVersion="337.88"
clgpu[0].CUDASupported=0
clgpu[1].CUDASupported=1
clgpu[1].CUDAVersion="6.0.1"
clgpu[0].CLBandwidth=2.1463e+010
clgpu[1].CLBandwidth=2.76797e+010
clgpu[0].CLCompute=92.9977
clgpu[1].CLCompute=234.245
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
You may also need to update the Intel drivers.

But it sounds like at least one of your drivers is crashing.
You should be able to identify which one by checking the crash report for the name of the faulting module.
Photo of Kurt Eakle

Kurt Eakle

  • 3 Posts
  • 0 Reply Likes
I tried updating the Intel HD4600 driver and it seems to work OK now.

One odd thing. If I use Photoshop CC x 64, under Prefences > Performance the GPU is recognized as NVidia 750M. If I use Photoshop CC2014, the GPU is recognized as Intel HD4600.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
I bet you changed the NVidia preferences to disable the Intel GPU (or prefer the NVidia GPU, depending on which version of the preferecnes you're looking at) in Photoshop CC, and forgot about making that change. You'll need to make the same change for CC (2014).
Photo of Rafaël Croonen

Rafaël Croonen

  • 1 Post
  • 1 Reply Like
Had the same problem on HP envy.
Thanks to this blog I suddenly realised Photoshop was using the integrated graphics card and not the nVidia 750M.
In the nVidia Controll panel > Manage 3D settings > Program settings I changed the settings for Photoshop from global to High performance NVVIDIA.

Voila! Now the card is recognised by Photoshop.