Problems with LR4

  • 1
  • Problem
  • Updated 6 years ago
I have used Lightroom since its inception and LR4 for the last several weeks. Until recently, my opinion of LR is that it is an excellent product, even though there were some slowness issues with the initial release of LR3. I have noticed the following things with LR4 that leave me unhappy.

1. Slow.
2. Slow.
3. It is slow when cycling between images and in loading changes to images, to the extent that you actually see the updated image snap onto the screen a second of two after the image is on the screen. It goes from unedited to edited image. This is most obvious on cropped images but occurs on all edited images.

4. Changes in submodules in Develop sometimes take tens of seconds or longer to load/become available. Worse, when selecting some functions within those submodules, changes are not accepted immediately, causing multiple attempts to make one edit.

5. Background processes, within LR seem to slow the product down. Background processes within the OS slow it down further.

6. The most serious complaint I have involves the interface between LR4 and PS5. In attempting to edit an image in PS5, I have found that the LR edits to RAW images (specifically Canon CR2 for the IDs MarkII) are not transferred to PS5 and are not picked up by LR4 when the image comes back. This results in work being lost and that is totally unacceptable.

This does not appear to occur once an image has been converted tp a non RAW format, though I have not tested all possible instances.

I hope your next release will address these problems.

FWIW My OS is 10.7.3.
Photo of Robert W Stockdale

Robert W Stockdale

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1

Be the first to post a reply!