Lightroom mobile (iOS): Problems using selective editing

  • 2
  • Question
  • Updated 56 seconds ago
  • (Edited)
Hi I hope someone can help me.. I am using Lightroom mobile for iPad.. my iPad is the iPad pro 12.9 2017 with 256gb of storage. My issue is this.. when I edit a raw image (Nef file from D800) in Lightroom mobile it lags like crazy... When I am making a selective adjustment it seems to take the brush a long time to catch up which makes it almost impossible to do any serious editing. Has anyone else experienced this issue.. I am seriously frustrated with this issue.. I really like the idea of using Lightroom on my iPad but not like this. My Adobe photography subscription is due for renewal on the 25th October 2018 and if Lightroom mobile is going to be like this then I will not be renewing my subscription.. in fact I have already installed Affinity Photo on my IPad pro with a view to using this instead of Lightroom and already I can see a huge performance difference in the 2 ... So it is critical that someone offers some advice before I csncec my Adobe subscription.. Thank you in advance..
Photo of Mapleleaf56

Mapleleaf56

  • 4 Posts
  • 0 Reply Likes

Posted 2 weeks ago

  • 2
Photo of Christian Fürst

Christian Fürst

  • 97 Posts
  • 27 Reply Likes
try to close all other Apps not needed for yr editing. And, yes, sometimes the brush reacts with several seconds of lag

Photo of Mapleleaf56

Mapleleaf56

  • 4 Posts
  • 0 Reply Likes
I always only have Lightroom mobile open.. never anything else open..
I have tried everything.. last evening I gave it one more try and at first all seemed well but when I attempted to do a second selective edit on the same photybut a different area it lagged like crazy..
I find it frustrating and rather disappointing that Adobe offer a product that obviously is so inferior it's is ridiculous..
Photo of Guido Reule

Guido Reule, Employee

  • 73 Posts
  • 14 Reply Likes
Do you see this after a force restart of Lr Mobile as well? - Guido/ Lr  Mobile QE
Photo of Mapleleaf56

Mapleleaf56

  • 4 Posts
  • 0 Reply Likes
Yes I do..
I have tried everything I know.. restarted.. reinstalled.. but always the same.. it does the first selective edit fine but then it lags do bad it becomes unusable..
Photo of Sergey Zhdanko

Sergey Zhdanko

  • 3 Posts
  • 2 Reply Likes
I have the same problem. I am using iPad pro 10.5" 512 Gb which is very fast but selective editing (brush especially) is a big pain (Nikon D800/Sony A7Rii). Only Lightroom CC is open (always latest version of app and iOS), originals are stored on the iPad. I have to wait couple seconds to see changes to the mask. Pick WB tool is laggy too. This is unbelievable. In other hand Affinity photo is buttery smooth with lots of layers. Why? Because of optimisation.
Photo of Mapleleaf56

Mapleleaf56

  • 4 Posts
  • 0 Reply Likes
Although I'm sorry you are having problems.. I am glad it's not just me!
I thought maybe the new update this week would fix it but unfortunately it didn't. I am now resigned to not renewing my subscription with Adobe and sticking with Affinity Photo because as you say Sergey it is buttery smooth and I own it!!
Absolutely shameful Adobe..