Lightroom: Problem with spacing and character width and danish national characters using flash web templates.

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
LR4, problem in flash template based web site (HTML based template site ok) with danish national characters in title and caption (only ones used).

'1æøå2ÆØÅ3' becomes '1æøå 2ÆØÅ3' (space after å, too narrow space after ø, ÆØÅ too compact). I can provide screen dump if needed.
Photo of Jan Straegaard

Jan Straegaard

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of Jan Straegaard

Jan Straegaard

  • 4 Posts
  • 0 Reply Likes
How can I may Adobe aware of this problem?

/Jan
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes
This is exactly the place for that (i.e. posting a problem) since the old bug report form was deactivated. However, it varies from problem to problem how fast Adobe reacts to it. Sometimes, it takes a little while (but a month is really long indeed).

I don't know what exact etiquette applies here concerning "thread bumps", but if there is no reaction, I would think that it is legitimate way to draw attention to the problem again. I just did the same in another thread, too ;-)
Photo of Jan Straegaard

Jan Straegaard

  • 4 Posts
  • 0 Reply Likes
The problems still excist in 4.2. Adobe, please wake up!
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 38 Reply Likes
Might be a font problem. Did you have this problem in earlier versions? Earlier than LR4...
Photo of Jan Straegaard

Jan Straegaard

  • 4 Posts
  • 0 Reply Likes
It is apparently related to the font. In flash albums the "Myriad Web Pro" is used and in HTML albums it is the Helvetica family.

The text I use for testing is "Fra Skiathos til Skopelos –aæaøaåaaÆaØaÅa"

If I changed the font in the styles.xml (flash album) to e.g. Arial, the text is shown correctly. If I put the text in a Word document or a Notepad and apply the "Myriad Web Pro" font, the text is shown correctly.

I have attached a 'clip' from a screenshot of the flash album.

I do not recall using flash albums with LR3. I will try to install it (LR3.6) on another PC.
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 38 Reply Likes
As far as I know, if a font is missing a certain glyph, the application (or is the OS?) replace it with an existing glyph from a similar font. Naturally, the substitute may not perfectly match the style or metrics of the substituted font.

So, Myriad Web Pro might just be missing some glyphs.

As for HTML, if you specify helvetica, on Windows, perhaps Arial is being used.