Problem after upgrade to Lightroom 5

  • 1
  • Problem
  • Updated 4 years ago
After I upgraded to Lightroom 5 hundreds of my photos now say "The file appears to be unsupported or damaged." Searched web for options on how to correct and tried everything. Nothing worked. Called tech support and got a guy in India that could not really speak English that well. After 3 hours of him remoted into my machine he said bad hard drive and that was all he could do. It is not a hard drive issue. This issue is only with .NEF files as I have the camera set to write both .NEF & . JPG files for each shot and the JPG files open fine; again further underscoring it is not a drive issue. Unfortunately for me while the tech support guy was in my machine he lost all of my edits on thousands of images and deleted a number of catalogs. The problem has only effected photos that I imported from card following upgrade. I have since re-installed Lightroom 4 and the problem still persists. The .NEF files that have this problem can be opened in other editing applications, but DO NOT WORK in any Photoshop apps.

Am shooting with Nikon D800. HELP PLEASE ANYBODY...
Photo of Carl Ceresoli

Carl Ceresoli

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
The files may indeed be corrupted by bad hardware:

Most other apps that deal with NEF files only look at the camera-embedded preview JPG that is small and near the beginning of the file, rather than actually decoding the raw data from the NEF, so those other apps seem to be working but are using different data.

However, if you have touched (viewed, transferred) the NEFs with an obsolete version of Nikon Transfer or Nikon View NX then that old Nikon software can render the files unrecognizable by Adobe software.

There is a utility from the following website that will fix that specific sort of corruption:
http://owl.phy.queensu.ca/~phil/exift...

If you can't figure it out, then upload one of these NEFs to www.dropbox.com and post a public download link to it, here, and someone else can test it.
Photo of Carl Ceresoli

Carl Ceresoli

  • 3 Posts
  • 0 Reply Likes
Downloaded app, did not work. Link to public dropbox file is below.

https://dl.dropboxusercontent.com/u/8...

Thanks...
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
I downloaded your sample NEF from dropbox. Something does seem to be wrong with it.

LR 5.3 doesn't like it. LR 4.4 doesn't like it. PS-CC/ACR 8.4 RC doesn't like it.

RawDigger is ok with it and doesn't show any missing pixels from the raw data.

RawTherapee is ok with it and doesn't have any issues with the raw data.

http://regex.info/exif.cgi reports: Warning Error reading OtherImage from file

There appears to be some corruption of some data in the file, though some raw processing programs can deal with the data just fine.

Do you have a backup copy of any of the images?
Photo of Carl Ceresoli

Carl Ceresoli

  • 3 Posts
  • 0 Reply Likes
Ok, just uploaded two files. One is directly from the SD Card(DSC6485), the other is after importing into Lightroom 5(Untitled-118). One that went through import process now has error. Other than name, they are same file.

https://dl.dropboxusercontent.com/u/8...

https://dl.dropboxusercontent.com/u/8...
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
ExifTool reports that the NEF that works has four images contained in it:

7360 × 4912 (JpgFromRaw)
1632 × 1080 (OtherImage)
570 × 375 (PreviewImage)
raw data

The image that does not work has only three of these:\

7360 × 4912 (JpgFromRaw)
570 × 375 (PreviewImage)
raw data
and ExifTool reports that the OtherImage is missing.



I wonder if MicrosoftPhoto has done something to the file.

Both example images seem to have been taken last year. Does this issue occur on brand-new D800 images or is it just something that is showing up for older images that have sat on your hard-drive a while and maybe some other process has caused problems.

Do you have other D800 NEFs that are ok that have also been imported into LR5? I'd like to see one of those, along with the original from your initial backup.