Photoshop 21.0.1: Problem with Smudge Tool

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)
I know that if you use the smudge tool in a selected area, it will pull in some color if you start outside the selected area.  However, it now seems to be pulling in color from the end of the stroke not just the beginning.  Even if you get close to the outside, the end color seems to be pulled in making it very difficult to use the tool particularly with small selections.  Since I use the smudge tool to create my style in almost all pictures, it is causing a severe problem with my workflow.
Photo of Joseph Vittek

Joseph Vittek

  • 54 Posts
  • 8 Reply Likes

Posted 8 months ago

  • 1
Photo of Joseph Vittek

Joseph Vittek

  • 54 Posts
  • 8 Reply Likes
Update   The problem seems to be caused by pulling too hard and showing the layer below.  I have used this tool since CS 6 at 51% without this happening.  Now even at 1% it is pulling away the surface as it moves the contents. 

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17043 Posts
  • 2897 Reply Likes
Can you make a video or screen shots to show what you're describing?
Photo of Joseph Vittek

Joseph Vittek

  • 54 Posts
  • 8 Reply Likes
I was able to take a rather shaky shot on my phone and my daughter managed to save it in my e-mail but I don't know how to get that to you.  I need a forwarding address via email. 

Thanks.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17043 Posts
  • 2897 Reply Likes
Is it an ongoing problem you can reproduce? You can simply attach a screenshot or video by clicking the camera or video camera icon in the reply box here.
Photo of Joseph Vittek

Joseph Vittek

  • 54 Posts
  • 8 Reply Likes
I have responded to you before.  Just a few days ago I indicated that I did have a short movie showing my problems with the smudge tool but I am not computer literate enough to know how to get it to you.  It is connected to an email but I don't have a way to send it to you.  If you would send an email address I will forward it.  However, I have sent other problems like the period and comma not advancing through the brush pallet as described.  I encounter long delays when I change almost anything while using the program.  On occasion it just freezes and I have to restart the computer.  

I use paths and the smudge tool to create my work. I  need many different brushes which for years I stacked together to be able to move back and forth using period and comma.  I see many similar complaints from users who have similar but different problems using other tools.  And the number of freeze complaints is growing all the time.

I was a machine language programmer for many years.  I programed part of the software for the SR 71 spy plane.  I was program director for the MIT guidance for Apollo 7.  I was program director for the original software for the Navy's Deep Submergence Rescue Vehicle.  If any of the software for any of those programs had as many bugs as the latest versions of PS, I would probably still be in military prison somewhere.

Stop putting in new stuff that probably makes things run slower and gate the basics right!

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17043 Posts
  • 2897 Reply Likes
You can send the video to jtranber at adobe dot com. We really need to see whole screen so we can see the options bar, the state of the document and layers panel. A direct screen capture would be best.

Have you tried resetting the Tool settings for the smudge tool to make sure there isn't a setting off? https://helpx.adobe.com/photoshop/kb/basic-troubleshooting.html#tool

It may help if we could see yourPhotoshop System Info. Launch Photoshop, and select Help > System Info...and copy/paste the text in a reply.