Lightroom Classic: problem with search

  • 2
  • Problem
  • Updated 4 months ago
  • Not a Problem
  • (Edited)
Since upgrading to Lightroom Classic CC the text search rarely works.  

Right now I am searching for specific filename, but it tells me no photo matches the filter.  I KNOW it is there.  So I search on a specific keyword I know it has, same thing.  I search any searchable field - same thing.

I go to the keyword list and find the keyword I'm looking for.  Click the arrow to filter to that keyword and it works.  aaahh - there is my photo, it IS there!

Both attribute and metadata searches work, it just appears to be the text search, which is of course my most used!

This is extremely annoying.  It always worked perfectly prior to upgrading
Photo of Jill Terry

Jill Terry

  • 6 Posts
  • 0 Reply Likes
  • very frustrated

Posted 4 months ago

  • 2
Photo of Roelof Moorlag

Roelof Moorlag

  • 94 Posts
  • 24 Reply Likes
Could it be that you searched while not in 'all photograps' ? That would explain it.
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1356 Posts
  • 310 Reply Likes
If you could attach a screen shot of your Library Search Filter we could probably spot the issue. 
Photo of Jill Terry

Jill Terry

  • 6 Posts
  • 0 Reply Likes
Thanks folks.

Definitely made sure I was in 'all photographs' and no other meta data filtered.  Did the same as I have always done.

However, this morning it's been behaving itself and has worked every time!!  Typical as it has happened at least a few times every day since upgrading!

When it happens again I shall post a screen shot, although not sure how that will help as I always check every other filter is off.
Photo of drobtitan


  • 29 Posts
  • 7 Reply Likes
Just to be sure that the problem is not worse, try the following: backup all your photographs and the Lightroom catalog

In Lightroom click the right arrow of every keyword to see if each one shows results in the grid.

Now the crucial test: if you select the menu option: Metadata -> Purge Unused Keywords it may delete several of your keywords without warning, even if they are assigned or not.  This is a serious bug in Lightroom.
Photo of Jill Terry

Jill Terry

  • 6 Posts
  • 0 Reply Likes
Thanks for the warning Drobitan!   I have been sorting my keywords and would have used the purge in a couple of days or so!