Lightroom Classic 8.0: Problem with blank main image display window in Develop module

  • 1
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
I would like some help with a bug that I have had since therelease of 8.0.

Whenever I have a photo open in the library module, and Iclick on the develop module tab, I go to the develop module, and everythingappears to be OK, except that the main image display window is black.  The preview window in the upper left corneris OK, and the histogram is fine.  I canmake any change to the exposure settings and see the histogram and preview windowschange accordingly.  I can go back to thelibrary module and the main image windows displays the selected photo, but onreturning to the develop module, the main image window is black.

I would say that this occurs on 19 out of 20 times that Iswap between the library tab and the develop tab.  On the 20th time, the develop tab opens justfine with the selected photo on display in the main image display window.

The only way to get out of this is to close LR while in developmode, and open LR up so that it opens in develop mode.  After it starts, I can see the main imagedisplay just fine.  I can work for hourswith no problem.  But, if I go to the librarytab, and then swap back to the develop tab, the main image display is againblack, and I have to restart LR to get the main image display widow to show theselected photo.

This has been going on a while.  I have wiped my hard drive once and reloadedeverything, and I have replaced the hard drive once, and reloaded everything.

I have updated my display drivers, and upgraded the bios onmy system.  I have tried two different monitors.

I’m using a Dell XPS Core i7 that is older, but stillsufficient for my needs.  I use Windows10 Pro.  I have used LR on this PC foryears with no problem until LR 8.0

I’m at the point of downloading trials for Luminar, ACDSEE,and Capture 1, but I just don’t want to try to learn a new interface (I’m goingto give Luminar another shot when they release their DAM module.)



Any help would be appreciated.
Photo of kbanes

kbanes

  • 3 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Tom Mickow

Tom Mickow

  • 339 Posts
  • 116 Reply Likes
Have you tried turning off the GPU?
Edit --> Preferences --> Performance tab --> Uncheck Use Graphics Processor
Photo of kbanes

kbanes

  • 3 Posts
  • 0 Reply Likes
Well.  Now. Don't I feel like an idiot.  Turning off the GPU certainly seems to have fixed my problem.  I had forgotten that that option even existed.  Its been turned on ever since that option was available.

Many thanks for your quick solution to my "bug".  I can't believe that I put up with a problem this easy to fix for so long.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4696 Posts
  • 952 Reply Likes
Video Drivers are the culprit. It is likely that there is an updated video driver for your video card.  If you go to the card manufacturer's website instead of Microsoft or Dell, you can get the latest driver. Note: If you have dual graphics cards you may need to update both. 

After updating your video drivers, you can try turning on the GPU again. 
Photo of kbanes

kbanes

  • 3 Posts
  • 0 Reply Likes
As I mentioned, I updated the video drivers the first time in rebuilt the system., after the problem occured.  That was my first thought.  But thanks for the help.

KB