Photoshop CC 2015.5: Ignoring ACLs on Mac OS X

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
I wanted to submit a bug report after running into this issue with a client and confirming it on my own system. This is with Adobe Photoshop CC 2015.5. According to the client the issue did not exist on 2015.4

The client has a SAN that uses ACLs to control permissions due to having multiple AD groups in use. They recently updated to Photoshop 2015.5 and immediately started having permission issues with PSD files. They were no longer able to save PSDs that other users had created. 

In looking into the issue I found that even though the ACLs were correct on the filesystem Photoshop was completely ignoring them and was defaulting to the POSIX permissions. POSIX on OS X are restricted to Owner R/W by default so this quickly became a problem. I verified it was only looking at POSIX by modifying the POSIX permissions on a test file (opened it to rwx-rw-r--) so that the group could write the file. This allowed the user to save the file which had been created by another user.

I also verified this on my own system running 2015.5 and found that when I created a new PSD file in a folder with ACLs the ACLs were not inherited by the PSD file. I then changed the POSIX permissions and verified that ACLs were being ignored. 

In my eyes (and the client's eyes) this is a major issue. Many people utilize ACLs in their shared storage environments for various reasons (like Premiere coming up with it's own POSIX permissions and zip files) and Photoshop ignoring those ACLs will cause problems. I am aware that you can change the POSIX after the fact and modify the umask to 002 but at the same time I shouldn't have to mess around with file system permissions to get Photoshop to work correclty in a shared storage environment. 

I do hope that this is solved in the next release of Photoshop.
Photo of Ethan Hansen

Ethan Hansen

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Pete Green

Pete Green, Customer Advocate

  • 710 Posts
  • 134 Reply Likes
Official Response
This issue is fixed in the Photoshop CC 2017.1 update

Please update Photoshop by clicking "Update" in the Creative Cloud desktop application next to Photoshop.