Lightroom Classic: Problem Google Maps in module "Map"

  • 15
  • Problem
  • Updated 19 hours ago
  • Solved
  • (Edited)
I posted this Question.

Out of the blue I have the error in the module “Map” in Lightroom CC 2015 shown as below I can’t fix. Can anybody help me please?

"Oops! Something went wrong. This page didn't load Google Maps correctly. See the JavaScript console for technical details".



The answer I got
See Map is no longer supported in this version of Lightroom

You'll have to upgrade to Classic CC 8.0 to get Maps working again.

My opinion
It's a scandel. I bought a Lightroom 6 licence 8 month ago. I understand that Adobe wants his customers to migrate to Lightroom Classic CC 8.0. But this is not the way to do this. Really outrageous!

This may be allowed according to the license, but that is not how you deal with paying customers.

I decide when I am about to go to a new version, and I will not force myself in this way. I also understand that you have to step over once, but this is like scam.

I am going to orient myself on DxO Photolab, Luminar, On1 and Affinity Photo. Sure I can find a good alternative in that.

I am going to say goodbye to all Abobe products that I have been paying for for years.

See our complete conversation on https://forums.adobe.com/thread/2567828
Photo of J. Groneveld

J. Groneveld

  • 2 Posts
  • 0 Reply Likes
  • Screwed, angry and disappointed.

Posted 2 weeks ago

  • 15
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4482 Posts
  • 890 Reply Likes
Official Response
Please See: https://helpx.adobe.com/lightroom/kb/map-view-no-longer-supported.html

Please contact support directly (https://helpx.adobe.com/contact.html) if you have more questions.
(Edited)