Photoshop Elements 10: Printing problem with Trial version.

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
Printing a Photo with Photoshop elements 10, on my laser (Brother HL 5040), gives a print with raster, as in a newspaper.
Printing the same Photo with "Photoshop elements organizer" gives a perfect printout as with any other Photo-Programm, with the same laser printer.
Photo of Viktor Wehrle

Viktor Wehrle

  • 7 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of PECourtejoie

PECourtejoie, Champion

  • 791 Posts
  • 282 Reply Likes
Hello!
It seems that one of them prints at lower resolution setting for the printer. Did you double-check the printer drivers settings?
Photo of Viktor Wehrle

Viktor Wehrle

  • 7 Posts
  • 0 Reply Likes
Hello
Thank you for your time.
Yes, I double checked.
It is set to 600 dpi both, when printing with PSE and when printing with PSE-organizer. But still a complete different result.

PSE


PSE-organizer
Photo of Viktor Wehrle

Viktor Wehrle

  • 7 Posts
  • 0 Reply Likes
Quote of an answer on a Printing problem with PSE 9
........ the two programs use very different print modules. The one in Organizer is designed for versatility, printing multiple images (contact sheet, picture package).
Printing from Editor is for quality, one image at a time but it is color managed and supports a higher DPI. So, if you are printing only one image at a time, I highly recommend avoiding the Organizer, it is always lower quality.

In my case with PSE 10, on Win7 64bit, it is exactly the other way round
PSE 10 Editor: poor quality printing
PSE 10 Organizer: better quality printing
Why has this changed?
Any suggestions to get it straight?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
The only thing that can change the quality like that is the printer driver. Photoshop could only control the halftone line frequency on PostScript printers, if the user chose to change it. On non-PostScript printers, the driver is in control.
Photo of Viktor Wehrle

Viktor Wehrle

  • 7 Posts
  • 0 Reply Likes
Thank you Chris
It is not quite clear, why using the same printer driver I get this results:
"PSE 10 Editor": poor quality printing
"PSE 10 Organizer": better quality printing

In both cases the setting is 600dpi.

Up till now I was using Paint Shop Pro. For various reasons I am evaluating an alternative product.
But I did not plan to change the good old Brother printer. The Brother HL-5040 is working reliable with all applications, except "PSE 10 Editor".
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
To Chris' point, you are not getting a lower quality print from Editor. The print has an applied Halftone effect, which is actually the result of higher end print capabilities. It's a PostScript function, but not one that Photoshop Elements supports.

Editor supports higher end print functions (such as Color Managements) where Organizer and most other applications do not. With Editor sending higher end commands to the printer, it could be enabling higher end functions that are normally dormant when dealing with lower end print commands.

I suggested checking through the printer driver settings and seeing if there is a way to enable/disable halftone. You can click the Advanced Settings button (or Erweiterte Einstellungen as in your screen shot) to get to these settings.
Photo of Viktor Wehrle

Viktor Wehrle

  • 7 Posts
  • 0 Reply Likes
We have tried with a new driver from Brother (PCL5e) and with all possible variations of parameters, but no success at all.

Printing with this Brother Laser works fine with
- Microsoft Office Picture Manager
- Paint Shop Pro X2
- PSE 10 Organizer

but never with
- PSE 10 Editor

After spending so many hours trying got get things working, we have to stop it and evaluate an alternative product.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
Have you tried disabling Halftoning or Improve Gray Printer (as seen in this dialog)?


Updating drivers, which we'd normally recommend for such issues, isn't an option. On Win7 or Vista you are just expected to use "Enhanced Generic PCL Driver for Windows" installed by the OS. For older systems, the driver was never updated beyond version 1.0 (2003).
Photo of Viktor Wehrle

Viktor Wehrle

  • 7 Posts
  • 0 Reply Likes
I remember the shown dialog from the time of Windows XP,
but today with Windows 7 the dialog looks as in the picture below.
Unfortunately the new dialog in Windows 7 has no parameter
to disabling Half toning or Improve Gray Printer.

Is there another solution when working with Windows 7?

Dialog for your printer with Windows 7

Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
This is where the problem of using a generic printer driver comes in, you don't have full control over the options in your device. It's probably a bug in the generic driver and it would require an update from Brother.

There probably isn't much that can be done at this point due to the above limitation. My only question is whether you have another similar printer that can be tested. I doubt we'd get the same behavior (assuming we're not using the same printer driver), but just for the sake of verification.

I'll still report this to our engineers to see if anything can be done on our side, but I have a feeling it's beyond our control.
Photo of Viktor Wehrle

Viktor Wehrle

  • 7 Posts
  • 0 Reply Likes
Thank you for your further investigations.

At the moment we have eliminated all other "Photo-printers" and only use the "old Laser" to check the Photos, before they are sent to an external Photo lab for professional digital printing.

After reading all comments again, it is still hard to believe,
that "PSE 10 organizer" can work successfully with our printer driver,
but "PSE 10 Editor" cannot.

Our currently used Paint shop Pro Photo X2 can also print perfetly with our printer driver. - no problem with generic printer driver

My superior would never agree to change to "PSE 10" if the problem resists, even there a number functions in "PSE 10" which would serve us very well.