Photoshop: Printing options limited with Epson r2880 (Mac OS 10.6.8)

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Using CS5.5 on OS X 10.6.8 with an Epson r2880 printer. No options for "Advanced Black and White", nor options for papers other than Epson. Epson says problem is Adobe's. Anybody else using this combo? Anybody else getting this problem?
Photo of Bernard Kane

Bernard Kane

  • 3 Posts
  • 0 Reply Likes
  • disappointed

Posted 7 years ago

  • 1
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 197 Posts
  • 49 Reply Likes
Do you have the latest drivers?

http://www.epson.com/cgi-bin/Store/su...
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 197 Posts
  • 49 Reply Likes
You also have to have Printer Manages Color and Epson Color Management on for those to be available.
Photo of Bernard Kane

Bernard Kane

  • 3 Posts
  • 0 Reply Likes
I downloaded and installed the newest drivers, and finally found most of what I needed. It is under "print settings" in the PS dialog box! A different place for it from the software that came with the printer. I will have to make some tests.

I was taught to have PS handle the color, but now the fuller functionality is available when the printer handles the color. That is 180 degrees different. Any idea why the change?
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 197 Posts
  • 49 Reply Likes
Advanced black and white is the printer managing the color, so to access it you need to select "Printer Manages Colors." It's a change from older versions, but in discussions with Epson we figured this was the more accurate way to represent things.
Photo of Bernard Kane

Bernard Kane

  • 3 Posts
  • 0 Reply Likes
I thank you for your help and replies. Of course, I wil have to test things out, but I will repost and let you know what I find.
Photo of Scott Weaver

Scott Weaver

  • 5 Posts
  • 0 Reply Likes
I cannot find "paper settings: source" when printing from Mac. It's very clear when printing in Windows 7. What am I missing? I need to tell the prints (r2880) that I'm using the "Manual-roll' option.