Elements 14: Printing problems with Epson 1400

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
For a year I have been using a new Dell computer with Windows 10--PSE14--Epson Photo Stylus 1400 with no problems. Printer is wired directly to computer. One day my photos started coming out darker, colors not right (greens now blues) and people's faces more orange. I have reloaded PSE14, have reloaded printer drivers, test pages on printer are perfect, and new ink. I have had Mircosoft check Windows 10, Epson check printer, Geek Squad has spent a few hours checking everything. No one can find a problem. I take the test photos to third party and they print fine. Where do I go for help since Adobe doesn't provide any online support? Is there someone out there who can fix this problem?
Photo of daryle holbrook

daryle holbrook

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of r

r

  • 11 Posts
  • 4 Reply Likes
Hello,

You've said you've reinstallled print drivers, however, have you checked on the color management or printer profile ?
Attempt to change the settings to let PE manage the colors and not the printer.
Photo of daryle holbrook

daryle holbrook

  • 2 Posts
  • 0 Reply Likes
Thanks for taking the time to respond.  Yes--none of my original settings have changed.  PE has always managed the colors.  I have checked all PSE 14 settings and printer settings.  I'm sure there is someone out there who can figure this out.  Sure wish Adobe had an online support system so someone could remotely take over my computer and fix this problem.