Print settings in Lightroom does not seem to reset and contain leftovers from previous printers installed even when long removed.

  • 1
  • Problem
  • Updated 2 years ago
I had problems with old settings from an HP printer being present in the commands sent to my new printer from both Photoshop and Lightroom. But after resetting print settings in Photoshop it works just fine.

In Lightroom it just won't go away (deleting prefs, uninstalling drivers/lightroom you name it).

It has things like com.hp.print.PrintSettingsST properties in the com.adobe.Lightroom6.plist files savedPrintInfo even if I haven't had the HP printer installed in years. The real offender is however an extra PageSize command which sets the size to A4 no matter what I set in the printer dialog.

What leads to believe it is a Lightroom issue (albeit a wierd one) is that no other software exhibits this and Lightroom from a different account on same machine behaves correctly. I have grep'ed the entire drive for anything matching those properties but haven't found anything.

Where does Lightroom pick these settings up if no other software does?

I can share the preference files and the resulting job file from /var/spool/cups
Photo of Ulf Nielsen

Ulf Nielsen

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 2 years ago

  • 1
Photo of Robert Frost

Robert Frost

  • 392 Posts
  • 51 Reply Likes
Not sure if this will cure your problem, but when you delete your LR prefs, if you have left any old prefs from earlier versions of LR, I believe LR will cannabalize those old prefs and copy some of their stuff into your new prefs. Make sure you delete all your old LR prefs or rename them. Worth a try!

Bob Frost