Lightroom Classic: Previews not rendering at correct resolution in full screen mode, causing blurry views

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
In my work flow I often use full screen mode from the Develop or Library modules. Occasionally, it looks as if the wrong resolution previews are being shown in that mode.

For example, when I'm in full screen mode and zoom to 1:1, a sharp image appears for about a second, and then it "degrades" and shows a slightly blurry preview that looks (to my eye), like a lower resolution image. If I zoom back out, the image will again appear sharp for a second and then degrade into a significantly blurry image (e.g., see attached for an example of how a sharp image looks degraded in full screen mode).



The image is not "loading". Instead, it almost appears that Lightroom is not correctly identifying what resolution preview to show, and often gets it wrong. This is making it difficult or impossible to judge image sharpness in full screen mode.

I can see the correctly rendered preview by leaving full screen mode and going back into either the Develop or Library modules.

I'm on a Mac using Lightroom Version 7.2, Camera Raw 10.2
Photo of Will Koeppen

Will Koeppen

  • 3 Posts
  • 0 Reply Likes
  • frustrated that this is an issue, because I just upgraded from LR5 which didn't have this problem.

Posted 2 months ago

  • 1
Photo of Will Koeppen

Will Koeppen

  • 3 Posts
  • 0 Reply Likes
Photo of Christian Fürst

Christian Fürst

  • 60 Posts
  • 14 Reply Likes
Will, I have the same problem. Not every time I open LR but every second or third time on a windows-PC with i7, fast SSD and 32 GB of RAM. It may have to do with memory managment by latest LR version. You will see that LR will get back to normal when you close it and then re-open. But it is - in my humble opinion - a bug
Photo of Will Koeppen

Will Koeppen

  • 3 Posts
  • 0 Reply Likes
Interesting idea about the memory management being a problem. Over the past week I've been noticing a host of issues like this one cropping up the longer that LR is open, so maybe that's it. I have the nearly the same setup (i7, fusion drive, 32 Gb RAM) but on Mac.