premiere elements 2018: click and drag adds files out of sequence

  • 1
  • Problem
  • Updated 9 months ago
Premiere elements 2018, Windows 10 (latest version). When "drag and drop" used to add files to the timeline in "Quick" mode then files are added out of sequence. 

For example, when adding files Vid00 to Vid31 by click and drag, the time line gets Vid24 to Vid31 followed by Vid00 to Vid23. And, when adding files Vid00 to Vid52, then the time line gets Vid30 to Vid52 followed by Vid00 to Vid29

The time sequence and the name sequence of the files would suggest they should be loaded in the sequence from Vid00 to Vid31/Vid52.

This appears to be a bug introduced by PrE 2018. A check using PrE 15 with exactly the same sets of files resulted in the files being loaded in the expected sequence.

Any suggestions or fixes?
Photo of Andy Video

Andy Video

  • 8 Posts
  • 2 Reply Likes

Posted 10 months ago

  • 1
Photo of Ann

Ann

  • 5 Posts
  • 0 Reply Likes
You need to be sure the clips are sorted by name in the Project Assets.
Select first, hold down shift, select last clip, then drag.
Photo of Andy Video

Andy Video

  • 8 Posts
  • 2 Reply Likes
Hi Ann - ACP,

Thanks for the suggestion. I have tried what (I think) you have suggested and unfortunately get the same, unwanted, result.

My precise actions are:
  1. Normally work in "Expert" mode
  2. when I want to add more clips (files) I go into "Quick" mode
  3. then select wanted files in Windows File Explorer (which happen to both in alphabetic and time order)
  4. then drag files directly across from Explorer to the PrE timeline, at the position where wanted. (I have found this to be more reliable than attempting to drag and drop while in "Expert" mode as it is then possible to accidentally "drop" into the middle of an existing clip on the timeline rather then between existing clips or at the end)
  5. then return to "Expert" mode and continue editing the new files etc
Note: as a general rule I never populate the timeline from the Project Assets list. But I did, as you suggested, do a test ensuring the ordering within Project Assets was alphabetical before I did a drag and drop in Quick mode directly to the timeline. I would also note that when in Quick mode "Project Assets" is not visible.

I have worked like this for several years with several previous versions of PrE without any problems. Only with PrE 2018 have I had a problem and it occurs every time (not just randomly correctly / incorrectly)

My current "workaround" in PrE 2018 is to go into Quick mode and then use "Add Media" and select the next batch of files wanted. This results in the clips going into the timeline in the correct order. However, unlike when I can use Windows File Explorer, the software always reverts to the first file in the folder, rather than where my last batch of files came from - which is a pain,e.g., if you have 1500 files in one folder and want to grab files 1023 to 1045 having recently grabbed 0988 to 1022.

I am still of the opinion that this is a bug in PrE 2018. The bug also seems to occur when drag and drop to the timeline is used in Expert mode. The bug seems to always result in the sequence fileAA to FileXX followed by file01 to file<AA-1> (instead of a straight sequence of file01 ...fileXX).