Premiere Elements 13: Projects default to NTSC, PAL unfriendly

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
Upgraded from Premiere Elements 10 to Premiere Elements 13. Selected United Kingdom as my region but Project Settings defaults to NTSC settings when I open the programme instead of PAL. Uninstalled and reinstalled both 10 and 13. 10 works fine but 13 does not. Still opens in NTSC settings. Also, 13 will not recognise PAL media in a new project empty timeline. Remains NTSC. Very annoying.
Photo of H M Dawson

H M Dawson

  • 1 Post
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Satish Ramakrishnan

Satish Ramakrishnan, Employee

  • 72 Posts
  • 11 Reply Likes
Hi,
Could you confirm the properties of the clips that you are importing into Premiere Elements 13 for the case when the project switch does not happen? Specifically:
1. The resolution
2. The frame rate
3. The format (extension and the codec - you can get this from Mediainfo tool)

To confirm, after you import the clip, do you see an orange line above the clip on the timeline (Check this in the Expert room)?

Regards,
Satish
Photo of Nic Franklin Woolley

Nic Franklin Woolley

  • 1 Post
  • 0 Reply Likes
This is so irritating - having to change the setting from NTSC to PAL for each new project using Premiere Elements 13. I have reinstalled the program selecting UK as the country and still the programme opens with the default as NTSC.

I am getting very annoyed with having to change settings to PAL for each new project as I do lots of video and now thinking of using a non Adobe video editor. Any suggestions welcome.