preferences reset without my permission

  • 1
  • Problem
  • Updated 2 weeks ago

Yesterday, and only yesterday, both Lightroom and Photoshop were running very slow. Both are the latest versions. And I'm running Mojave 10.14.3 (latest version I think).

 

Every tool had lag, both in Lightroom and Photoshop. Particularly the Adjustment Brush in Lightroom and the Normal Brush in Photoshop.

 

It was so bad I considered ending my contract and buying Affinity.....

 

New day, opened up Photoshop and found that my preferences had been reset, I saw a welcome screen that usually indicates a new version of the Photoshop had been installed, but it was exactly the same version as before.

 

Actions I had loaded some weeks ago were gone. The same for brushes I had loaded as well. Also, Styles I had created were gone but luckily saved in my CC Library.

 

More importantly, my performance had improved back to normal.

 

I did find out later that brush lag with Mojave can be caused by not allowing PS access in Accessibility Settings in Mojave. But, the performance of the brush in PS was fine. But, to be on the safe side I allowed PS access

 

I have now noticed all of my products have reset preferences and are treating me as a new user or at least someone who has just updated their software




Photo of Laurence Baker

Laurence Baker

  • 12 Posts
  • 0 Reply Likes
  • Angry

Posted 1 month ago

  • 1
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 836 Posts
  • 205 Reply Likes
Just get used to it. Worlds best image processing app in the world just can't save its settings in the cloud. Even if the word "cloud" is in its name. So you need to change settings after each upgrade which was in 2018 about 8×

If you consider Affinity, just do it. They have a relatively cheap perpetual licence. You can use both if you want to.

Meanwhile, even my computer mouse can save settings for its extra buttons into the could and sync it.
Photo of Carlos Cardona

Carlos Cardona

  • 354 Posts
  • 76 Reply Likes
I have NO idea what’s happening to your prefs! I’ve upgraded LR dozens of times without this issue. What gets old is people who don’t know the best Mac (or Windows) practices complaining about LR, when the ignored OS is to blame. I speak as a 25 year veteran of Mac IT engineering. Run Onyx & Disk Warrior once in a while, or do a clean install?
(Edited)
Photo of Laurence Baker

Laurence Baker

  • 12 Posts
  • 0 Reply Likes
Thanks Carlos, I hardly look at my Mac in that way, like I do my previous windows systems. I was brought up on the command line and DOS. I often if I'm a mug for buying a Mac!
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4978 Posts
  • 1013 Reply Likes
Likely this was due to the installation of Photoshop 20.0.3 and 8.2 that were briefly available last week and are officially released yesterday.  Sometimes I forget to check the status of the Preference box when doing uninstalls and installs/updates. 

Let us know if it happens again.
Photo of OneMore

OneMore

  • 3 Posts
  • 0 Reply Likes
It happened to me overnight.  When I opened Lightroom today, all of my preferences are gone.  It even walked me through the tips and offered to import my information from Photoshop Express (I haven't used that for 3 or 4 years)!
THe current version is 8.2 build 1204643.

Photo of Laurence Baker

Laurence Baker

  • 12 Posts
  • 0 Reply Likes
Thanks, Rikk, that would answer it, but boy did the performance improve after the prefs were reset. As I said my brushes etc were in CC library, so it's no great shakes.