Elements: PRE and PSE Editor won't run as non-administrator due to incorrect permissions

  • 1
  • Problem
  • Updated 9 years ago
  • Solved
  • (Edited)
The permissions on c:\Program Files\Common Files\Adobe\APE\3.1\adbeapecore.dll were not set correctly. It took me 3 days to find this problem. PSE and PRE worked fine if I installed them individually. When both were installed the PSE editor would get an exception when starting and terminate and PRE wouldn't even start. PRE upon starting would display "could not start. Please uninstall and reinstall the application". Using Microsoft's procmon I discovered PRE failed to open the dll above. The other dll's in the 3.1 folder were set to full access for everyone but adbeapecore.dll took the folder's permissions which were everyone read and administrator/system full access. At a minimum you may want to set permissions on this folder or file during installation. For better security set all executable code to everyone read and administrators full access and not have Adobe programs try to open them for read/write only read.
Photo of Brad Taylor

Brad Taylor

  • 1 Post
  • 0 Reply Likes

Posted 9 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16306 Posts
  • 2590 Reply Likes
Thanks for the info, Brad. I sent a note to the team to have them investigate.