Please Fix Brush Performance in Lightroom

  • 3
  • Problem
  • Updated 3 years ago
Brush performance (Adjustment, Graduated Filter and especially Spot removal) in Lightroom has been getting progressively worse with every release. I now get a multi-second delay between clicking and seeing the edit on the screen (on a relatively new MacbookPro with 16 gig of RAM. This is interspersed with system crashes when using brushes heavily.

This is such a fundamental feature that it must be rock solid.
Photo of Pedr

Pedr

  • 25 Posts
  • 12 Reply Likes

Posted 3 years ago

  • 3
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4493 Posts
  • 1687 Reply Likes
Can you please confirm which version of Lightroom you're using and which operating system please?
Photo of Pedr

Pedr

  • 25 Posts
  • 12 Reply Likes
I'm using OSX / Yosemite and the latest CC release - the now infamous 2015.2.1.
Photo of Ian Coggins

Ian Coggins

  • 4 Posts
  • 0 Reply Likes
I see the same.

LR6.2.1, windows 7, 16GB RAM, Catalog /previews on a Sata3 SSD, Corei5 3.4GHz processor, Nvidia GTX750ti Graphics card.

It's even worse if I have a second monitor enabled, and more so if that is in survey mode. (even with one image selected). Worse with survey mode, it records bogus brush strokes as well. :(
Photo of Pedr

Pedr

  • 25 Posts
  • 12 Reply Likes
Over the course of today I've had a full system crash twice (no other app has crashed my system since upgrading to Yosemite), and three or four times my system has locked up for minutes while using the Adjustment Brush. Even with a restart, using a single adjustment brush for the first time on an image, there is a huge delay before the results of my mouse moves are shown on the screen. As soon as I mouse-down, my fans kick in and run long after I mouse-up.

I am using other graphic-heavy apps like Resolve with no such issues.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 822 Reply Likes
A full system lockup/freeze, shutdown or reboot can only be caused by bugs in the OS, bugs in low level drivers, or defective hardware. Applications cannot cause those symptoms on modern OSes.
From the description, it does sound like your problem is somehow related to the GPU - either drivers or hardware.
Photo of Pedr

Pedr

  • 25 Posts
  • 12 Reply Likes
Well it only effects Lightroom and only when using the Adjustment Brush or Spot Removal Brush. No other applications have caused a system crash including Resolve (realtime playback of Prores video), Photoshop, Premiere Pro and Sketch (large complex files). Even if the lockup is down to drivers, the appalling performance of the brush tool is down to Lightroom which seems to become less performant with every release.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 822 Reply Likes
The low performance could be due to bugs in your video card driver, which might also explain the system shutdown.