Lightroom Classic: Placing photos on Map module erratic and slow since update LR Classic CC 7.5 (Windows)

  • 18
  • Problem
  • Updated 3 days ago
  • Solved
  • (Edited)
I geotag photos on a daily basis, and today, after updating LR Classic CC to version 7.5, I was going to resume my geotagging tasks as usual, but then I started to experience weird issues when placing photos on the map.

Most of the time, the problem is that I drag the photo from the filmstrip to the map (in the Map module, of course), and nothing happens (no photo on the map, no gps coordinates in the metadata). If I drag and hold the photo over the map for a few seconds before releasing the mouse button, sometimes it does place the photo.

I would say it's even more difficult when I select several photos and try to place them on the same spot at once, but I can't say absolutely for sure.

Also, selecting the photo (or photos) and then Ctrl+clicking (Windows) on the map to place them stopped working altogether as soon as I updated to 7.5, no matter how long I kept the keys or mouse button pressed down, or how many times I tried (previously, I was using this shortcut dozens of times a day).

Since I do need to keep geotagging photos, and with v7.5 it was much more difficult, I've downgraded to 7.4 and now things are working ok again. Of course I can't absolutely say for sure that this is an universal issue but... this is what's happening on my system. Any idea what could be going on? Thanks.

My first 10 lines in Help>Sytem info:

Lightroom Classic version: 7.5 [ 1186149 ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.17134
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 4,0 GHz
Built-in memory: 16314,6 MB
Photo of Carlos Oliveras

Carlos Oliveras

  • 103 Posts
  • 27 Reply Likes

Posted 1 month ago

  • 18
Photo of G0apher

G0apher, Adobe Employee

  • 19 Posts
  • 14 Reply Likes
Official Response
We are actively looking into this issue - it seems to intermittently occur in our test scenarios as well, albeit without a pattern. We are collecting a few logs and investigating the possible root cause. Hang on.

Apologies for the inconvenience, and thanks for being persistent!

Photo of G0apher

G0apher, Adobe Employee

  • 19 Posts
  • 14 Reply Likes
Official Response
Thanks for your patience!

We have upgraded the limits for the API again - request you to please give it a try and report any issues.

Joop, I understand your concern - but recent changes in our Map APIs mean that we have to make an API call over the internet to deduce the coordinates, as well as the geocode information. So, even if you have address lookup switched off, Lightroom does make an API call to deduce only the coordinates. Hope it clears your concerns!

Thanks again.