Photoshop: Will not auto word wrap, even in text boxes. Tried Rectangle, cut and paste. Nothing works.

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
Photoshop CS5 on my Macbook Pro will not auto word wrap. Clearly broken. Text boxes always shove my typing off to the right, I get a hyphen, then nothing! I cannot toggle on Paragraph in Layers; Type. Sometimes words will wrap, but only the top line of the text box, then leave a giant gap and type on the BOTTOM of the text box. Please help!
Photo of John Cone

John Cone

  • 5 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
Hi John,

Are you creating a text box by activating the Type tool and then clicking and dragging or are you creating point text by simply activating the Type tool and clicking? You do not use the rectangle marquee tool.

In the case of a text box, words should wrap. If they do not, I'd be happy to do a web-hosted screenshare to help get to the bottom of the problem.

In the case of point text, it's up to the user to define when the lines wrap with a < return >

Hope that helps,
David
Photo of John Cone

John Cone

  • 5 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Photoshop Text will not auto word wrap or go into Paragraph mode..


Photoshop CS5 on my Macbook Pro will not auto word wrap. Clearly broken. I cannot toggle on Paragraph in Layers; Type. Sometimes words will wrap, but only the top line of the text box, then the BOTTOM line. Please help!
Photo of John Cone

John Cone

  • 5 Posts
  • 0 Reply Likes
David, Thanks for your rapid and courteous assistance.

I was using the Text marquee. Also tried the Rectangle, then Text insert. Copy and paste from another doc, etc.

I found a fix - Reset Tool. Fixed all my worries. This is the longest it's taken me to resolve a problem in software by a long shot. Since 10, last night, with only a few hours sleep. You showed up on your white horse about 15 minutes too late, but I should have come here first. Still, that is not clear with Adobe.

Thanks again.
Photo of John Cone

John Cone

  • 5 Posts
  • 0 Reply Likes
This is the advice that helped me:

"Is one of your tools behaving strangely — or not the way you expect — in Photoshop?

For every tool in Photoshop's Tool Box, the user may choose to fully reset JUST that tool to its default settings. To do this, look up to the Options Bar. On the far left side you will see a button which displays an icon of the currently selected tool. This is the Tool Preset picker. Right-click on this button, and you will see two entries:

Reset Tool

Reset All Tools

The first thing to try when a tool is not acting like you expect it should is to apply the command "Reset Tool" from this menu. Often this will cure a problem, and by starting your Photoshop troubleshooting with this procedure you aren't resetting Photoshop's entire behavior and environment to factory default in a wholesale manner. Instead, you're just getting that particular tool back to its default settings, leaving the rest of Photoshop's settings alone."
Photo of blake adams

blake adams

  • 1 Post
  • 0 Reply Likes
I believe we had the same problem. Text tool revert to defaults didn't do much for me. Though I did open the character panel and saw that my line spacing was set at a very high number so the text was actually wrapping, but so far down below my text box that it didn't show. Which would make sense when you described "Sometimes words will wrap, but only the top line of the text box, then leave a giant gap and type on the BOTTOM of the text box"

Set the line spacing to auto or something more appropriate for your text box size and font size.
Photo of Jennifer Smith

Jennifer Smith

  • 2 Posts
  • 0 Reply Likes
I've never run into this problem before, but in my newly installed Photoshop CC 2017, the text won't wrap in the textbox.  I can't find a setting that does any good--nothing in the paragraph or character menus helps.  I can't even return.  So as of right now, I can only create one line of text in the box.  I would have to create multiple boxes to get more than one line.  Please Help!
Photo of David

David, Official Rep

  • 2682 Posts
  • 359 Reply Likes
Hi Jennifer,

I'd really like to see the problem that you're encountering.  There shouldn't be a way to turn off word-wrap for a text.

One thing that might be going on would be that you've set you Leading and/or your Space Before/After Paragraph to a value higher than what can be displayed in the text box.  You can quickly and easily clear either of these by going to the Character or Paragraph panel (respectively) and from the flyout menu clicking Reset Character / Paragraph.  Then try again.  Otherwise, please ping me here and I'll respond so we can get to the bottom of this.

Thanks,
David
Photo of Jennifer Smith

Jennifer Smith

  • 2 Posts
  • 0 Reply Likes
Thanks, David!

It looks like the problem was the leading.  The default was 220 pt.  Yikes!  I guess when you open a new file, you have to re-set it to something normal.  I just have to remember to do that each time.

Jennifer
Photo of David

David, Official Rep

  • 2682 Posts
  • 359 Reply Likes
Howdy Jennifer,

It might help you to know that Photoshop's text settings are "sticky."  Basically, they persist from the last text object you interacted with.  So, when you create a new document, we remember the last setting and apply it for you to that text, unless you change things.

Thanks,
David