Photoshop: CS5 unresponsive with Win 7 Aero enabled

  • 1
  • Problem
  • Updated 8 years ago
  • Solved
  • (Edited)
When I have both OpenGL drawing and Windows Aero enabled, Photoshop doesn't update the canvas area after I move window focus from Photoshop to another program and back. The rest of the interface works normally.

The obvious workaround is to disable OpenGL drawing or Windows Aero, but I'd rather not do either of those if possible.

Here's my system info:

Adobe Photoshop Version: 12.0.3 (12.0.3x20101211 [20101211.r.1222 2010/12/11:02:00:00 cutoff; r branch]) x64
Operating System: Windows 7 64-bit
Version: 6.1
System architecture: AMD CPU Family:15, Model:4, Stepping:2 with MMX, SSE Integer, SSE FP, SSE2, SSE3
Physical processor count: 3
Processor speed: 2800 MHz
Built-in memory: 6015 MB
Free memory: 2979 MB
Memory available to Photoshop: 5218 MB
Memory used by Photoshop: 75 %
Image tile size: 132K
Image cache levels: 4
OpenGL Drawing: Enabled.
OpenGL Drawing Mode: Basic
OpenGL Allow Normal Mode: False.
OpenGL Allow Advanced Mode: False.
OpenGL Crash File: Not Detected.
OpenGL Allow Old GPUs: Not Detected.
Video Card Vendor: NVIDIA Corporation
Video Card Renderer: nForce 750a SLI/PCI/SSE2
Display: 2
Display Bounds:= top: 0, left: 1920, bottom: 960, right: 3200
Display: 1
Display Bounds:= top: 0, left: 0, bottom: 1080, right: 1920
Video Card Number: 1
Video Card: NVIDIA nForce 750a SLI
Driver Version: 8.15.11.9038
Driver Date: 20090714000000.000000-000
Video Card Driver: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Video Mode: 1920 x 1080 x 4294967296 colors
Video Card Caption: NVIDIA nForce 750a SLI
Video Card Memory: 128 MB
Photo of n0nl1nearsb0x

n0nl1nearsb0x

  • 4 Posts
  • 0 Reply Likes
  • annoyed

Posted 8 years ago

  • 1
Photo of Anita Dennis

Anita Dennis

  • 75 Posts
  • 24 Reply Likes
If you're using OpenGL, you might want to disable Aero. See http://kb2.adobe.com/cps/404/kb404898....
Photo of n0nl1nearsb0x

n0nl1nearsb0x

  • 4 Posts
  • 0 Reply Likes
So this is just the way it works? I can't use OpenGL and Aero at the same time?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15633 Posts
  • 2368 Reply Likes
Two things to try first:

1. Upgrade to the latest version of PS CS5 (12.0.4): http://adobe.ly/PS-Up-To-Date
2. Make sure you have the latest video drivers for your video card by going directly to the nVidia site..

It's worth noting that you have a video card with very little VRAM (128MB). What is happening with Aero enabled is both Windows and Photoshop are competing for what little VRAM you have available. One or the other might work ok, but not both at the same time. Getting a card with more VRAM would certainly help.
Photo of n0nl1nearsb0x

n0nl1nearsb0x

  • 4 Posts
  • 0 Reply Likes
Upgrading Photoshop now. I checked the Nvidia site already, I am on the latest.

Ah, okay. This is just the onboard card on my motherboard, perhaps I should indeed get a real card. :)
Photo of n0nl1nearsb0x

n0nl1nearsb0x

  • 4 Posts
  • 0 Reply Likes
Updating to 12.0.4 did not solve the problem.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15633 Posts
  • 2368 Reply Likes
Official Response
Yeah. I think getting a real card with more video ram will make a huge difference for you. 128mb simply isn't enough to do what you're asking. If you look at the system requirements for Photoshop, 256MB is the bare minimum for OpenGL Features:

Photoshop CS5 / Tech specs