Photoshop: Re-opens most recently closed psd file when saving a new psd file.

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
(This is for PS CC, 14.2.1 x64.)

Steps to reproduce:
1. After editing a PSD file, save the file and close it.
2. Go to bridge, and double-click a new file (open in ACR), then press "Open Image" to open image in PS.
3. Save file (as a PSD) in PS. Immediately after the file save is complete, the file closed in step 1 will be re-opened.
Photo of Ken Brown

Ken Brown

  • 6 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 815 Reply Likes
I don't think anyone else is seeing that.
You most likely have an automation plugin, or an event script setup that is doing that.

Try disabling third party plugins, and make sure that Event Scripts (File->Scripts -> Script Event Manager) are not enabled.
Photo of Ken Brown

Ken Brown

  • 6 Posts
  • 0 Reply Likes
Event Scripts are not enabled, however I did add an automation plugin (Perfect Effects 8) immediately after installing PS CC that I never used in PS CS6. That must be the culprit if no one else is reporting this.

I don't know how to disable it, but I will look into it and report back.

Thank you!

Update: I renamed the plugin's folder (thus preventing it from loading successfully), and could no longer reproduce the problem. However, after renaming the folder back to its original name (and verifying that the plugin does load), I STILL can't reproduce the problem. (That's despite being able to reproduce it consistently for the past week, at least.) So I'm baffled, but happy. If I learn anything more I'll post here, but for now, it seems to be solved. Thanks again.
Photo of Ken Brown

Ken Brown

  • 6 Posts
  • 0 Reply Likes
It happened again, so I again disabled the plugin by renaming its folder, but this time it did not "fix" the problem -- it's still happening.

Well, maybe someone else will run into this problem and that will shed more light on it.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 815 Reply Likes
Since Photoshop itself can't do that, it has to be a script, a plugin, or something outside of Photoshop.
Photo of Ken Brown

Ken Brown

  • 6 Posts
  • 0 Reply Likes
Ok, thank you Chris, that's good to know, though I really can't imagine what could be causing the problem. It's annoying, but I'll just have to live with it I guess.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14190 Posts
  • 1787 Reply Likes
If you go to File>Scripts>Scripts Event Manager... is it enabled?
Photo of Ken Brown

Ken Brown

  • 6 Posts
  • 0 Reply Likes
No it is not enabled. (I mentioned that in my first reply above, but you may have missed or forgotten that.)

I see there's one more 3rd-party automation plug-in that I hadn't disabled -- the Nik Collection Selective Tool. That must be bundled with all Nik plugins, as I don't know what it is or how to use it. But since Nik plugins are quite popular, if that were causing the problem I suspect others would have noticed it as well.

I have a friend who uses PS CC, and who also has Perfect Effect 8 (and possibly the Nik bundle, but I'm not sure). She was not able to reproduce my problem. She's running Win 7 (64-bit) rather than Win 8, but I don't see that as being a likely possible cause.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14190 Posts
  • 1787 Reply Likes
There were some bugs with the Selective Tool with the older versions.

Do you have the latest Nik plug-ins installed? https://support.google.com/nikcollect...

You can find out the version you have installed by launching Photoshop:

On Mac: Select Photoshop>About Plug-in>(Select the Plug-in name)...

On Windows: Select Help>About Plug-in>(Select the Plug-in name)...
Photo of Ken Brown

Ken Brown

  • 6 Posts
  • 0 Reply Likes
I think the Nik stuff updates automatically. The information shown is:
Version 2.1.16.216 x64 1202 (1.1.1.1)
which I assume equates to the latest version shown in the link you gave, 1.111. Why they use two different numbering systems is beyond me, though.