Photoshop: Photoshop not the default application for .JPG files

  • 2
  • Problem
  • Updated 4 years ago
  • (Edited)
After installing CS5, I noticed that Photoshop is not the default program to open all my JPEG files. I tried to choose that program as my default and it doesn't even show up as a program available to do that when I click "open with" in the file menu. I also noticed that when I go to all my folder files and the extension .jpg is not a part of any photos I have on my computer. How can I default Photoshop as the program to open my photos?
Photo of Ashby Reed

Ashby Reed

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 2
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1208 Posts
  • 166 Reply Likes
Gee, that might depend on your OS, don’t you think?

On a Mac the File Info’s Open With-setting can be applied to all files of that format by clicking the »Change All«-button.
Photo of Ashby Reed

Ashby Reed

  • 3 Posts
  • 0 Reply Likes
Gee that was helpful. Thanks anyway.
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1208 Posts
  • 166 Reply Likes
Gee, I have to admit I had superficially browsed your post and missed that the application is missing completely from the list ... my apologies.

Have you run the usual System Maintenance (repairing permissions etc.) yet?
What happens if you try to add the file name extension manually?
Again only relevant for Mac: Is Finder > Preferences > Advanced > Show all filename extensions checked?
Photo of Ashby Reed

Ashby Reed

  • 3 Posts
  • 0 Reply Likes
I am so sorry, I took your note as a sarcastic response to a PC impaired person. I learned on the MAC and was forced to switch by a corporate edict.

I will try to see if I can translate that path in PC, LOL.

THANKS FOR KIND RESPONSE.
Photo of Jean Farrell

Jean Farrell

  • 2 Posts
  • 1 Reply Like
If you translated successfully to PC - please can you tell me how - I have the same problem!
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1208 Posts
  • 166 Reply Likes
So do you work on Macintosh or Windows?
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 197 Posts
  • 49 Reply Likes
Can you try this.

1. Right click on file.
2. Open with "choose default Program"
3. When that dialog comes up. Click on "Browse..."
4. Navigate to Photoshop install location.
5. Select the Photoshop.exe
6. Click OK.
7. Check "Always use this program" check box
8. OK again

Does that help?

As for the .jpg not showing up in the file name.

1. Open the explorer window.
2. hit the "alt" key to show the menus
3. Tools:Folder options...
4. Click on the view tab
5. uncheck "Hide extensions for known file types"
6. OK
7. OK
Photo of Martin Vaughan

Martin Vaughan

  • 2 Posts
  • 0 Reply Likes
please can i come in on this thread? i have just upgraded from elements 7 to elements 10 and since then elements has disappeared as my default to open jpg images. i have been through all the steps that david outlines above, but to no avail - elements 10 still doesn't become entered into the list of programmes that you can select from. ( OS windows XP)

i wondered if it was because i hadn't registered my product - but i have now done this and it still doesn't appeat in the list of "registered programmes" from which you can select the programme to open files.
would be very grateful for any sugestions
martin vaughan
Photo of Linda Savadian

Linda Savadian

  • 1 Post
  • 0 Reply Likes
Just found this 3yr old "Help, How To:" question and wanted to say, "THANK YOU David Dobish for your steps!"

I've had the same issue when opening a JPG file at work and PHOTOSHOP was not an option. I couldn't find it and hate the nonsense Windows Photo Viewer, which can't do anything, not "save as," nor resize, crop, etc.

From the top list I was able to do 1-6, though never got #7 "always us this prgm" ... but at least I now have Photoshop as an option in my list!

At work I open a handful of JPG daily just to view, not needing to edit, I really need to sit down and try to "play with & learn" Photoshop. I know that most people likely know this like the back of their hand, but being that I use it only on rare occasions, still a newbie. At home I had purchased Elements from Costco a few yrs ago, though I've never made the time to learn it and I know I need to make a project to scan my personal photos and save them. My sister has become quite the expert over the yrs w/ Elements. Me? Didn't make the time to learn or see the need to learn it.

Again, this step by step has been a HUGE HELP, and for me, the first major baby step to get motivated to do at home!

Linda S.
======================================================================

David Dobish (Senior QE Photoshop) over 2 years ago
Can you try this.

1. Right click on file.
2. Open with "choose default Program"
3. When that dialog comes up. Click on "Browse..."
4. Navigate to Photoshop install location.
5. Select the Photoshop.exe
6. Click OK.
7. Check "Always use this program" check box
8. OK again