Photoshop: Masks not applying

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
I can't get layer masks to Apply in CC (most recent version). If I choose to Apply a mask on an object then create a new layer mask to the same object, I get the same mask as if it never applied. I know this by clicking on the mask eye and there in red is what was supposed to be applied earlier. And working on the newer mask results in basically adding or subtracting from the first mask.

Here's a movie to show.
http://goo.gl/u4GQbQ
Photo of John Weber

John Weber

  • 48 Posts
  • 4 Reply Likes

Posted 5 years ago

  • 1
Photo of Jeanne Rubbo

Jeanne Rubbo, Employee

  • 125 Posts
  • 27 Reply Likes
Hi John,

I took a look at your video, and I'm having trouble seeing what method you're using to create a new mask after applying the first mask. I am unable to reproduce the issue, so I want to make sure I am following the same steps.

Thanks!
Photo of John Weber

John Weber

  • 48 Posts
  • 4 Reply Likes
Hi Jeanne

Years ago I wanted to create a keyboard shortcut to create mask before made a selection etc I found the easiest (and only) way was to use Reveal All. This creates a mask that is ready to use and isn't based on anything. Plus I don't have to use the palette.
(Funny how I've never looked to see what the shortcut was actually doing after all this time. But it's always worked.)
So I used that shortcut for the first mask. Then chose Apply. Then used the shortcut again. As I said I've been using this combo for a very long time but never had the first mask reappear after applying.

The only thing I can think is that the new mask is somehow being made based on From Transparency. I don't know why as the shortcut is not based on that menu item.
Photo of Jeanne Rubbo

Jeanne Rubbo, Employee

  • 125 Posts
  • 27 Reply Likes
Thanks for the info. I tried the same steps with an assigned keyboard shortcut and am still not able to reproduce it. Are you having the same problem if you use the Layers panel button (or Layer menu option) to create the mask? Have you checked your keyboard shortcut assignment?