Elements Organizer: Can not launch

  • 9
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
I have no problem getting Editor to launch and as far as I can see, is working fine. However can't get Organizer to launch at all.

In the "Welcome" screen when I click on Organizer, for a fraction of a second "launch Organizer" flashes in the top right of the screen, and a bar appears for a short while as if it is trying to load photos, then disapears and nothing happens. Has anyone any good ideas on what I need to try next? I have tried re-installing the disc a couple of times with no joy in getting the Organizer to work. I have also created a shortcut for the organizer and that didn't work. I have tried to reset the preferences but I can't get to that menu. When I hold down ctrl, alt, shift nothing comes up! Very frustrating! I would appreciate any help and advice. Thanks
Photo of Lisa Craven

Lisa Craven

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 9
Photo of Brett N

Brett N, Official Rep

  • 2208 Posts
  • 98 Reply Likes
Official Response
You could try manually recreating the preferences. Simply remove/rename the folder here:
WinXP: C:\Documents and Settings\[User Name]\Application Data\Adobe\Elements Organizer\[Version number]\Organizer
WinVista/7: C:\Users\[User Name]\Roaming\App Data\Adobe\Elements Organizer\[Version number]\Organizer

Additionally, test with a new catalog. Simply hold down the shift key at launch to bring up the Catalog Manager before the Organizer opens. If this fails to work, you can do the same sort of manual override. If you move or rename the default catalog folder, the Organizer will ask you where it is or let you create a new catalog. The default location for Catalogs is:
WinXP: C:\Documents and Settings\All Users\Application Data\Adobe\Elements Organizer\Catalogs
WinVista/7: C:\Program Data\Adobe\Elements Organizer\Catalogs