Photoshop Elements 10 Organizer "Not Responding" on Windows 7

  • 7
  • Problem
  • Updated 6 years ago
I purchased a new Lenovo Y570 laptop and a new boxed version of Photoshop Elements 10 yesterday. The OS is Windows 7 Home Premium 64 bit.

I installed the proper Windows 7 version of Photoshop Elements 10.

I transferred all my images from an external hard drive to the Pictures folder library on the new laptop. I have over 120GB of images.

When I open Photoshop Elements 10 Organizer it attempts to load files. When it gets to 100% it freezes and displays "Not Responding".

After several unsuccessful attempts, it now shows nothing in the Organizer preview pane. The message says "No items match this combination of filters".

What is the problem? What can I do to use the Organizer?

Russell
Dallas, TX
Photo of Russell Fife

Russell Fife

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 7
Photo of Anthony Antolik

Anthony Antolik

  • 1 Post
  • 0 Reply Likes
Am having the same problem. It just started after using the Organizer for several months with no problems. I'm about ready to delete the entire program.
Photo of Andromeda14

Andromeda14, Employee

  • 105 Posts
  • 7 Reply Likes
Hi Russell,
It may be possible that either your preference file got corrupted or there are some issues with your current catalog. Please try following workarounds-

Delete your preference file and try launching Organizer:
The preference file is located at (last file mentioned in the hierarchy)-
C:\Users\\AppData\Roaming\Adobe\Elements Organizer\11.0\Organizer\psa.prf
Rename this file (say to psa_old.prf). Right click the Organizer exe and select 'Run as Administrator'.

Delete preferences file and launch Organizer with a new catalog:
Delete the preference file using above steps. Now press 'shift' key and then double click Organizer exe. 'Catalog manager' dialog will open. In this dialog create a new catalog. Hopefully Organizer will launch. If so, open the catalog manager again (File->manage catalogs), select the catalog (which has issues) and click 'Repair' button followed by clicking on 'Optimize' button and then try to open this catalog.

Please let me know the outcome.

~Andromeda